Browse Source

python: refine packaging and split more modules into packages

Rule of thumb is: any Python file that is greater than 100kb
(or adds a dependency with which it adds more than 100 kb)
should be a pretty useful/commonly used lib to stay in `python-light`.
An example, is the Python IO lib, which summarized (Python source +
binary module) is over 200kb.

Also moved some files that should have been put into previously
existing packages before, and re-organized the packages a bit.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 years ago
parent
commit
d69d8ec0b9

+ 1
- 0
lang/python/files/python-package-codecs.mk View File

@@ -12,6 +12,7 @@ $(call Package/python/Default)
12 12
 endef
13 13
 
14 14
 $(eval $(call PyBasePackage,python-codecs, \
15
+	/usr/lib/python$(PYTHON_VERSION)/encodings \
15 16
 	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_codecs_cn.so \
16 17
 	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_codecs_hk.so \
17 18
 	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_codecs_iso2022.so \

+ 16
- 0
lang/python/files/python-package-compiler.mk View File

@@ -0,0 +1,16 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-compiler
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) compiler module
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-compiler, \
15
+	/usr/lib/python$(PYTHON_VERSION)/compiler \
16
+))

+ 18
- 0
lang/python/files/python-package-ctypes.mk View File

@@ -0,0 +1,18 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-ctypes
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) ctypes module
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-ctypes, \
15
+	/usr/lib/python$(PYTHON_VERSION)/ctypes \
16
+	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_ctypes.so \
17
+	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_ctypes_test.so \
18
+))

lang/python/files/python-package-bsddb.mk → lang/python/files/python-package-db.mk View File

@@ -5,13 +5,14 @@
5 5
 # See /LICENSE for more information.
6 6
 #
7 7
 
8
-define Package/python-bsddb
8
+define Package/python-db
9 9
 $(call Package/python/Default)
10
-  TITLE:=Python $(PYTHON_VERSION) bsddb module
10
+  TITLE:=Python $(PYTHON_VERSION) db module
11 11
   DEPENDS:=+python-light +libdb47
12 12
 endef
13 13
 
14
-$(eval $(call PyBasePackage,python-bsddb, \
14
+$(eval $(call PyBasePackage,python-db, \
15 15
 	/usr/lib/python$(PYTHON_VERSION)/bsddb \
16 16
 	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_bsddb.so \
17
+	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/dbm.so \
17 18
 ))

+ 0
- 16
lang/python/files/python-package-dbm.mk View File

@@ -1,16 +0,0 @@
1
-#
2
-# Copyright (C) 2006-2015 OpenWrt.org
3
-#
4
-# This is free software, licensed under the GNU General Public License v2.
5
-# See /LICENSE for more information.
6
-#
7
-
8
-define Package/python-dbm
9
-$(call Package/python/Default)
10
-  TITLE:=Python $(PYTHON_VERSION) dbm module
11
-  DEPENDS:=+python-light +libdb47
12
-endef
13
-
14
-$(eval $(call PyBasePackage,python-dbm, \
15
-	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/dbm.so \
16
-))

+ 16
- 0
lang/python/files/python-package-decimal.mk View File

@@ -0,0 +1,16 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-decimal
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) decimal module
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-decimal, \
15
+	/usr/lib/python$(PYTHON_VERSION)/decimal.py \
16
+))

+ 16
- 0
lang/python/files/python-package-distutils.mk View File

@@ -0,0 +1,16 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-distutils
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) distutils
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-distutils, \
15
+	/usr/lib/python$(PYTHON_VERSION)/distutils \
16
+))

+ 16
- 0
lang/python/files/python-package-email.mk View File

@@ -0,0 +1,16 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-email
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) email module
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-email, \
15
+	/usr/lib/python$(PYTHON_VERSION)/email \
16
+))

+ 16
- 0
lang/python/files/python-package-logging.mk View File

@@ -0,0 +1,16 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-logging
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) logging module
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-logging, \
15
+	/usr/lib/python$(PYTHON_VERSION)/logging \
16
+))

+ 17
- 0
lang/python/files/python-package-multiprocessing.mk View File

@@ -0,0 +1,17 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-multiprocessing
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) multiprocessing
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-multiprocessing, \
15
+	/usr/lib/python$(PYTHON_VERSION)/multiprocessing \
16
+	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_multiprocessing.so \
17
+))

+ 1
- 0
lang/python/files/python-package-ncurses.mk View File

@@ -12,6 +12,7 @@ $(call Package/python/Default)
12 12
 endef
13 13
 
14 14
 $(eval $(call PyBasePackage,python-ncurses, \
15
+	/usr/lib/python$(PYTHON_VERSION)/curses \
15 16
 	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_curses.so \
16 17
 	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_curses_panel.so \
17 18
 ))

+ 1
- 0
lang/python/files/python-package-pydoc.mk View File

@@ -12,6 +12,7 @@ $(call Package/python/Default)
12 12
 endef
13 13
 
14 14
 $(eval $(call PyBasePackage,python-pydoc, \
15
+	/usr/lib/python$(PYTHON_VERSION)/doctest.py \
15 16
 	/usr/lib/python$(PYTHON_VERSION)/pydoc.py \
16 17
 	/usr/lib/python$(PYTHON_VERSION)/pydoc_data \
17 18
 ))

+ 16
- 0
lang/python/files/python-package-unittest.mk View File

@@ -0,0 +1,16 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-unittest
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) unittest module
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-unittest, \
15
+	/usr/lib/python$(PYTHON_VERSION)/unittest \
16
+))

+ 20
- 0
lang/python/files/python-package-xml.mk View File

@@ -0,0 +1,20 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python-xml
9
+$(call Package/python/Default)
10
+  TITLE:=Python $(PYTHON_VERSION) xml libs
11
+  DEPENDS:=+python-light
12
+endef
13
+
14
+$(eval $(call PyBasePackage,python-xml, \
15
+	/usr/lib/python$(PYTHON_VERSION)/xml \
16
+	/usr/lib/python$(PYTHON_VERSION)/xmllib.py \
17
+	/usr/lib/python$(PYTHON_VERSION)/xmlrpclib.py \
18
+	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_elementtree.so \
19
+	/usr/lib/python$(PYTHON_VERSION)/lib-dynload/pyexpat.so \
20
+))