Quellcode durchsuchen

gst1-libav: Update to 1.4.4, disable CPU optimizations as in ffmpeg

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess vor 10 Jahren
Ursprung
Commit
d77c9b88ce
1 geänderte Dateien mit 24 neuen und 3 gelöschten Zeilen
  1. 24
    3
      multimedia/gst1-libav/Makefile

+ 24
- 3
multimedia/gst1-libav/Makefile Datei anzeigen

@@ -8,14 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-libav
11
-PKG_VERSION:=1.2.3
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=1.4.4
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
16 16
 PKG_SOURCE:=gst-libav-$(PKG_VERSION).tar.xz
17 17
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-libav
18
-PKG_MD5SUM:=58c7998a054d8d8ca041fa35738f72b6
18
+PKG_MD5SUM:=64a3e2cda2687132cadca4efdc63f3b4
19 19
 
20 20
 PKG_LICENSE:=GPL-2.0 LGPL-2.0
21 21
 PKG_LICENSE_FILES:=COPYING COPYING.LIB
@@ -148,6 +148,7 @@ CONFIGURE_ARGS += \
148 148
 	--without-system-libav \
149 149
 	--with-libav-extra-configure="--target-os=linux \
150 150
 	--disable-bsfs \
151
+	--disable-programs \
151 152
 	--disable-devices \
152 153
 	--disable-encoders \
153 154
 	$(LIBAV_CONFIGURE_ENCODERS) \
@@ -161,6 +162,26 @@ CONFIGURE_ARGS += \
161 162
 	$(LIBAV_CONFIGURE_PARSERS) \
162 163
 	--disable-protocols \
163 164
 	$(LIBAV_CONFIGURE_PROTOCOLS) \
165
+	--disable-asm \
166
+	--disable-altivec \
167
+	--disable-amd3dnow \
168
+	--disable-amd3dnowext \
169
+	--disable-mmx \
170
+	--disable-mmxext \
171
+	--disable-sse \
172
+	--disable-sse2 \
173
+	--disable-sse3 \
174
+	--disable-ssse3 \
175
+	--disable-sse4 \
176
+	--disable-sse42 \
177
+	--disable-avx \
178
+	--disable-xop \
179
+	--disable-fma3 \
180
+	--disable-fma4 \
181
+	--disable-avx2 \
182
+	--disable-vfp \
183
+	--disable-neon \
184
+	--disable-inline-asm \
164 185
 	--disable-yasm"
165 186
 
166 187
 # XXX: trick to force use of embedded Libav headers