Browse Source

Copy liboil package from old repository

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 10 years ago
parent
commit
d81d7ebe5e
1 changed files with 66 additions and 0 deletions
  1. 66
    0
      libs/liboil/Makefile

+ 66
- 0
libs/liboil/Makefile View File

@@ -0,0 +1,66 @@
1
+# 
2
+# Copyright (C) 2007-2010 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=liboil
11
+PKG_VERSION:=0.3.17
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
16
+PKG_MD5SUM:=47dc734f82faeb2964d97771cfd2e701
17
+
18
+PKG_FIXUP:=autoreconf
19
+PKG_INSTALL:=1
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+
23
+define Package/liboil
24
+  SECTION:=libs
25
+  CATEGORY:=Libraries
26
+  TITLE:=simple functions optimized for various CPUs
27
+  URL:=http://liboil.freedesktop.org/wiki/
28
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
29
+  DEPENDS:=+librt
30
+endef
31
+
32
+define Package/liboil/description
33
+  Liboil is a library of simple functions that are optimized for various CPUs.
34
+  These functions are generally loops implementing simple algorithms, such as
35
+  converting an array of N integers to floating-point numbers or multiplying
36
+  and summing an array of N numbers. Such functions are candidates for significant
37
+  optimization using various techniques, especially by using extended instructions
38
+  provided by modern CPUs (Altivec, MMX, SSE, etc.).
39
+endef
40
+
41
+CONFIGURE_ARGS += \
42
+	--enable-shared \
43
+	--enable-static \
44
+
45
+TARGET_CFLAGS += $(FPIC)
46
+
47
+# XXX: VFP_CFLAGS is set to '-mfpu=vfp' on arm by configure, but that breaks 
48
+# final linking stages, so override it until we find why
49
+MAKE_FLAGS += \
50
+	VFP_CFLAGS="" \
51
+
52
+define Build/InstallDev
53
+	$(INSTALL_DIR) $(1)/usr/include
54
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/liboil-0.3/* $(1)/usr/include/
55
+	$(INSTALL_DIR) $(1)/usr/lib
56
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.{a,so*} $(1)/usr/lib/
57
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
58
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/liboil-0.3.pc $(1)/usr/lib/pkgconfig/
59
+endef
60
+
61
+define Package/liboil/install
62
+	$(INSTALL_DIR) $(1)/usr/lib
63
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.so.* $(1)/usr/lib/
64
+endef
65
+
66
+$(eval $(call BuildPackage,liboil))