Просмотр исходного кода

ipsec-tools: fix null dereference in racoon

 * add a patch to fix a null pointer dereference in src/racoon/gssapi.c (CVE-2015-4047)
 * refresh patches
 * bumb release number

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 9 лет назад
Родитель
Сommit
d8362b6d04

+ 2
- 2
net/ipsec-tools/Makefile Просмотреть файл

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2011 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #               2014 Noah Meyerhans <frodo@morgul.net>
4 4
 #
5 5
 # This is free software, licensed under the GNU General Public License v2.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
11 11
 
12 12
 PKG_NAME:=ipsec-tools
13 13
 PKG_VERSION:=0.8.2
14
-PKG_RELEASE:=2
14
+PKG_RELEASE:=3
15 15
 PKG_MAINTAINER := "Noah Meyerhans <frodo@morgul.net>"
16 16
 PKG_LICENSE := BSD-3-Clause
17 17
 

+ 2
- 2
net/ipsec-tools/patches/002-patch8-utmp.patch Просмотреть файл

@@ -9,7 +9,7 @@
9 9
  #if defined(__APPLE__) && defined(__MACH__)
10 10
  #include <util.h>
11 11
  #endif
12
-@@ -1661,7 +1661,8 @@ isakmp_cfg_accounting_system(port, raddr
12
+@@ -1664,7 +1664,8 @@ isakmp_cfg_accounting_system(port, raddr
13 13
  	int inout;
14 14
  {
15 15
  	int error = 0;
@@ -19,7 +19,7 @@
19 19
  	char addr[NI_MAXHOST];
20 20
  	
21 21
  	if (usr == NULL || usr[0]=='\0') {
22
-@@ -1670,34 +1671,37 @@ isakmp_cfg_accounting_system(port, raddr
22
+@@ -1673,34 +1674,37 @@ isakmp_cfg_accounting_system(port, raddr
23 23
  		return -1;
24 24
  	}
25 25
  

+ 1
- 1
net/ipsec-tools/patches/003-microsoft-fqdn-in-main.patch Просмотреть файл

@@ -1,6 +1,6 @@
1 1
 --- a/src/racoon/ipsec_doi.c
2 2
 +++ b/src/racoon/ipsec_doi.c
3
-@@ -3582,8 +3582,8 @@ ipsecdoi_checkid1(iph1)
3
+@@ -3581,8 +3581,8 @@ ipsecdoi_checkid1(iph1)
4 4
  	    iph1->approval->authmethod == OAKLEY_ATTR_AUTH_METHOD_PSKEY) {
5 5
  		 if (id_b->type != IPSECDOI_ID_IPV4_ADDR
6 6
  		  && id_b->type != IPSECDOI_ID_IPV6_ADDR) {

net/ipsec-tools/patches/force_HAVE_POLICY_FWD → net/ipsec-tools/patches/007-force_have_policy_fwd.patch Просмотреть файл

@@ -1,8 +1,6 @@
1
-diff --git a/configure.ac b/configure.ac
2
-index 8506245..eca8895 100644
3 1
 --- a/configure.ac
4 2
 +++ b/configure.ac
5
-@@ -724,7 +724,8 @@ case $host in
3
+@@ -732,7 +732,8 @@ case $host in
6 4
  			],
7 5
  			[AC_MSG_RESULT(yes)
8 6
  			 AC_DEFINE([HAVE_POLICY_FWD], [], [Have forward policy])],

+ 16
- 0
net/ipsec-tools/patches/008-racoon-fix_dereference_crash.patch Просмотреть файл

@@ -0,0 +1,16 @@
1
+Fix null dereference in racoon/gssapi.c (CVE-2015-4047)
2
+
3
+--- a/src/racoon/gssapi.c
4
++++ b/src/racoon/gssapi.c
5
+@@ -192,6 +192,11 @@ gssapi_init(struct ph1handle *iph1)
6
+ 	gss_name_t princ, canon_princ;
7
+ 	OM_uint32 maj_stat, min_stat;
8
+ 
9
++	if (iph1->rmconf == NULL) {
10
++		plog(LLV_ERROR, LOCATION, NULL, "no remote config\n");
11
++		return -1;
12
++	}
13
++
14
+ 	gps = racoon_calloc(1, sizeof (struct gssapi_ph1_state));
15
+ 	if (gps == NULL) {
16
+ 		plog(LLV_ERROR, LOCATION, NULL, "racoon_calloc failed\n");