|
@@ -16,14 +16,14 @@ include $(INCLUDE_DIR)/nls.mk
|
16
|
16
|
include $(INCLUDE_DIR)/target.mk
|
17
|
17
|
|
18
|
18
|
PKG_NAME:=boost
|
19
|
|
-PKG_VERSION:=1_57_0
|
20
|
|
-PKG_RELEASE:=3
|
|
19
|
+PKG_VERSION:=1_58_0
|
|
20
|
+PKG_RELEASE:=4
|
21
|
21
|
|
22
|
22
|
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
23
|
23
|
PKG_SOURCE_URL:=@SF/boost
|
24
|
24
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
|
25
|
25
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_VERSION)
|
26
|
|
-PKG_MD5SUM:=25f9a8ac28beeb5ab84aa98510305299
|
|
26
|
+PKG_MD5SUM:=5a5d5614d9a07672e1ab2a250b5defc5
|
27
|
27
|
PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
|
28
|
28
|
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
|
29
|
29
|
|
|
@@ -34,6 +34,7 @@ PKG_USE_MIPS16:=0
|
34
|
34
|
include $(INCLUDE_DIR)/package.mk
|
35
|
35
|
include $(INCLUDE_DIR)/host-build.mk
|
36
|
36
|
|
|
37
|
+
|
37
|
38
|
define Package/boost/Default
|
38
|
39
|
SECTION:=libs
|
39
|
40
|
CATEGORY:=Libraries
|
|
@@ -135,7 +136,7 @@ endef
|
135
|
136
|
$(eval $(call DefineBoostLibrary,atomic,system,))
|
136
|
137
|
$(eval $(call DefineBoostLibrary,chrono,system,))
|
137
|
138
|
$(eval $(call DefineBoostLibrary,container,,))
|
138
|
|
-$(eval $(call DefineBoostLibrary,context,,))
|
|
139
|
+$(eval $(call DefineBoostLibrary,context,chrono system thread,))
|
139
|
140
|
$(eval $(call DefineBoostLibrary,coroutine,system chrono context thread,))
|
140
|
141
|
$(eval $(call DefineBoostLibrary,date_time,,))
|
141
|
142
|
#$(eval $(call DefineBoostLibrary,exception,,))
|
|
@@ -149,6 +150,10 @@ $(eval $(call DefineBoostLibrary,math,,))
|
149
|
150
|
#$(eval $(call DefineBoostLibrary,mpi,,))
|
150
|
151
|
$(eval $(call DefineBoostLibrary,program_options,,))
|
151
|
152
|
$(eval $(call DefineBoostLibrary,random,system,))
|
|
153
|
+
|
|
154
|
+# We need a beter way to provide this package, information regarding the Python packages
|
|
155
|
+# such as Python version and directories locations.
|
|
156
|
+# Python 2.7 version is for now hard-coded. Python 3 is (until this date) broken in the trunk tree.
|
152
|
157
|
$(eval $(call DefineBoostLibrary,python,,+PACKAGE_boost-python:python))
|
153
|
158
|
$(eval $(call DefineBoostLibrary,regex,,))
|
154
|
159
|
$(eval $(call DefineBoostLibrary,serialization,,))
|