|
@@ -1,6 +1,6 @@
|
1
|
1
|
--- a/Makefile
|
2
|
2
|
+++ b/Makefile
|
3
|
|
-@@ -557,16 +557,7 @@ EXTRA_PROGRAMS =
|
|
3
|
+@@ -559,16 +559,7 @@ EXTRA_PROGRAMS =
|
4
|
4
|
# ... and all the rest that could be moved out of bindir to gitexecdir
|
5
|
5
|
PROGRAMS += $(EXTRA_PROGRAMS)
|
6
|
6
|
|
|
@@ -17,7 +17,7 @@
|
17
|
17
|
|
18
|
18
|
# Binary suffix, set to .exe for Windows builds
|
19
|
19
|
X =
|
20
|
|
-@@ -923,6 +914,11 @@ BUILTIN_OBJS += builtin/verify-pack.o
|
|
20
|
+@@ -929,6 +920,11 @@ BUILTIN_OBJS += builtin/verify-pack.o
|
21
|
21
|
BUILTIN_OBJS += builtin/verify-tag.o
|
22
|
22
|
BUILTIN_OBJS += builtin/worktree.o
|
23
|
23
|
BUILTIN_OBJS += builtin/write-tree.o
|
|
@@ -29,7 +29,7 @@
|
29
|
29
|
|
30
|
30
|
GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
|
31
|
31
|
EXTLIBS =
|
32
|
|
-@@ -1106,7 +1102,7 @@ endif
|
|
32
|
+@@ -1112,7 +1108,7 @@ endif
|
33
|
33
|
EXTLIBS += -lz
|
34
|
34
|
|
35
|
35
|
ifndef NO_OPENSSL
|
|
@@ -38,7 +38,7 @@
|
38
|
38
|
ifdef OPENSSLDIR
|
39
|
39
|
BASIC_CFLAGS += -I$(OPENSSLDIR)/include
|
40
|
40
|
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
|
41
|
|
-@@ -1977,10 +1973,6 @@ endif
|
|
41
|
+@@ -1989,10 +1985,6 @@ endif
|
42
|
42
|
git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
|
43
|
43
|
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
|
44
|
44
|
|
|
@@ -49,7 +49,7 @@
|
49
|
49
|
git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
|
50
|
50
|
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
|
51
|
51
|
$(CURL_LIBCURL) $(LIBS)
|
52
|
|
-@@ -2300,10 +2292,11 @@ endif
|
|
52
|
+@@ -2312,10 +2304,11 @@ endif
|
53
|
53
|
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
|
54
|
54
|
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
|
55
|
55
|
{ test "$$bindir/" = "$$execdir/" || \
|
|
@@ -64,7 +64,7 @@
|
64
|
64
|
} && \
|
65
|
65
|
--- a/builtin.h
|
66
|
66
|
+++ b/builtin.h
|
67
|
|
-@@ -141,5 +141,10 @@ extern int cmd_verify_pack(int argc, con
|
|
67
|
+@@ -142,5 +142,10 @@ extern int cmd_verify_pack(int argc, con
|
68
|
68
|
extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
|
69
|
69
|
extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
|
70
|
70
|
extern int cmd_replace(int argc, const char **argv, const char *prefix);
|
|
@@ -97,7 +97,7 @@
|
97
|
97
|
+#include "../upload-pack.c"
|
98
|
98
|
--- a/daemon.c
|
99
|
99
|
+++ b/daemon.c
|
100
|
|
-@@ -1184,7 +1184,7 @@ static int serve(struct string_list *lis
|
|
100
|
+@@ -1178,7 +1178,7 @@ static int serve(struct string_list *lis
|
101
|
101
|
return service_loop(&socklist);
|
102
|
102
|
}
|
103
|
103
|
|
|
@@ -106,28 +106,17 @@
|
106
|
106
|
{
|
107
|
107
|
int listen_port = 0;
|
108
|
108
|
struct string_list listen_addr = STRING_LIST_INIT_NODUP;
|
109
|
|
-@@ -1380,12 +1380,13 @@ int main(int argc, char **argv)
|
|
109
|
+@@ -1374,6 +1374,7 @@ int main(int argc, char **argv)
|
110
|
110
|
write_file(pid_file, "%"PRIuMAX, (uintmax_t) getpid());
|
111
|
111
|
|
112
|
112
|
/* prepare argv for serving-processes */
|
113
|
|
-- cld_argv = xmalloc(sizeof (char *) * (argc + 2));
|
114
|
|
-- cld_argv[0] = argv[0]; /* git-daemon */
|
115
|
|
-- cld_argv[1] = "--serve";
|
116
|
|
-+ cld_argv = xmalloc(sizeof (char *) * (argc + 3));
|
117
|
|
-+ cld_argv[0] = "git";
|
118
|
|
-+ cld_argv[1] = argv[0]; /* daemon */
|
119
|
|
-+ cld_argv[2] = "--serve";
|
|
113
|
++ argv_array_push(&cld_argv, "git"); /* git-daemon */
|
|
114
|
+ argv_array_push(&cld_argv, argv[0]); /* git-daemon */
|
|
115
|
+ argv_array_push(&cld_argv, "--serve");
|
120
|
116
|
for (i = 1; i < argc; ++i)
|
121
|
|
-- cld_argv[i+1] = argv[i];
|
122
|
|
-- cld_argv[argc+1] = NULL;
|
123
|
|
-+ cld_argv[i+2] = argv[i];
|
124
|
|
-+ cld_argv[argc+2] = NULL;
|
125
|
|
-
|
126
|
|
- return serve(&listen_addr, listen_port, cred);
|
127
|
|
- }
|
128
|
117
|
--- a/fast-import.c
|
129
|
118
|
+++ b/fast-import.c
|
130
|
|
-@@ -3380,7 +3380,7 @@ static void parse_argv(void)
|
|
119
|
+@@ -3381,7 +3381,7 @@ static void parse_argv(void)
|
131
|
120
|
read_marks();
|
132
|
121
|
}
|
133
|
122
|
|
|
@@ -138,7 +127,7 @@
|
138
|
127
|
|
139
|
128
|
--- a/git.c
|
140
|
129
|
+++ b/git.c
|
141
|
|
-@@ -311,11 +311,11 @@ static int handle_alias(int *argcp, cons
|
|
130
|
+@@ -307,11 +307,11 @@ static int handle_alias(int *argcp, cons
|
142
|
131
|
|
143
|
132
|
struct cmd_struct {
|
144
|
133
|
const char *cmd;
|
|
@@ -152,7 +141,7 @@
|
152
|
141
|
{
|
153
|
142
|
int status, help;
|
154
|
143
|
struct stat st;
|
155
|
|
-@@ -396,6 +396,7 @@ static struct cmd_struct commands[] = {
|
|
144
|
+@@ -392,6 +392,7 @@ static struct cmd_struct commands[] = {
|
156
|
145
|
{ "config", cmd_config, RUN_SETUP_GENTLY },
|
157
|
146
|
{ "count-objects", cmd_count_objects, RUN_SETUP },
|
158
|
147
|
{ "credential", cmd_credential, RUN_SETUP_GENTLY },
|
|
@@ -160,7 +149,7 @@
|
160
|
149
|
{ "describe", cmd_describe, RUN_SETUP },
|
161
|
150
|
{ "diff", cmd_diff },
|
162
|
151
|
{ "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE },
|
163
|
|
-@@ -414,6 +415,7 @@ static struct cmd_struct commands[] = {
|
|
152
|
+@@ -410,6 +411,7 @@ static struct cmd_struct commands[] = {
|
164
|
153
|
{ "grep", cmd_grep, RUN_SETUP_GENTLY },
|
165
|
154
|
{ "hash-object", cmd_hash_object },
|
166
|
155
|
{ "help", cmd_help },
|
|
@@ -168,7 +157,7 @@
|
168
|
157
|
{ "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
|
169
|
158
|
{ "init", cmd_init_db, NO_SETUP },
|
170
|
159
|
{ "init-db", cmd_init_db, NO_SETUP },
|
171
|
|
-@@ -463,6 +465,7 @@ static struct cmd_struct commands[] = {
|
|
160
|
+@@ -459,6 +461,7 @@ static struct cmd_struct commands[] = {
|
172
|
161
|
{ "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
|
173
|
162
|
{ "rm", cmd_rm, RUN_SETUP },
|
174
|
163
|
{ "send-pack", cmd_send_pack, RUN_SETUP },
|
|
@@ -176,7 +165,7 @@
|
176
|
165
|
{ "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
|
177
|
166
|
{ "show", cmd_show, RUN_SETUP },
|
178
|
167
|
{ "show-branch", cmd_show_branch, RUN_SETUP },
|
179
|
|
-@@ -479,6 +482,7 @@ static struct cmd_struct commands[] = {
|
|
168
|
+@@ -476,6 +479,7 @@ static struct cmd_struct commands[] = {
|
180
|
169
|
{ "update-server-info", cmd_update_server_info, RUN_SETUP },
|
181
|
170
|
{ "upload-archive", cmd_upload_archive },
|
182
|
171
|
{ "upload-archive--writer", cmd_upload_archive_writer },
|
|
@@ -186,7 +175,7 @@
|
186
|
175
|
{ "verify-pack", cmd_verify_pack },
|
187
|
176
|
--- a/imap-send.c
|
188
|
177
|
+++ b/imap-send.c
|
189
|
|
-@@ -1496,7 +1496,7 @@ static int curl_append_msgs_to_imap(stru
|
|
178
|
+@@ -1494,7 +1494,7 @@ static int curl_append_msgs_to_imap(stru
|
190
|
179
|
}
|
191
|
180
|
#endif
|
192
|
181
|
|
|
@@ -208,7 +197,7 @@
|
208
|
197
|
const char **user_argv;
|
209
|
198
|
--- a/upload-pack.c
|
210
|
199
|
+++ b/upload-pack.c
|
211
|
|
-@@ -819,7 +819,7 @@ static int upload_pack_config(const char
|
|
200
|
+@@ -820,7 +820,7 @@ static int upload_pack_config(const char
|
212
|
201
|
return parse_hide_refs_config(var, value, "uploadpack");
|
213
|
202
|
}
|
214
|
203
|
|