Browse Source

ngircd: update to release 22.1

Also enable IPv6 by default, depending on the OpenWrt
build config.

Signed-off-by: Claudio Leite <leitec@staticky.com>
Claudio Leite 9 years ago
parent
commit
d9de90c82a
1 changed files with 16 additions and 3 deletions
  1. 16
    3
      net/ngircd/Makefile

+ 16
- 3
net/ngircd/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2008-2012 OpenWrt.org
2
+# Copyright (C) 2008-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ngircd
11
-PKG_VERSION:=18
11
+PKG_VERSION:=22.1
12 12
 PKG_RELEASE:=1
13 13
 PKG_MAINTAINER:=Claudio Leite <leitec@staticky.com>
14 14
 PKG_LICENSE:=GPL-2.0
@@ -18,7 +18,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
18 18
 PKG_SOURCE_URL:= \
19 19
         http://ngircd.barton.de/pub/ngircd/ \
20 20
         ftp://ftp.berlios.de/pub/ngircd/
21
-PKG_MD5SUM:=4958c8b2d128cf3e9888af3f782892a1
21
+PKG_MD5SUM:=586c4fef1fbb77dcbe723e9136ec08eb
22 22
 
23 23
 PKG_INSTALL:=1
24 24
 
@@ -71,6 +71,11 @@ define Package/ngircd-nossl/description
71 71
   This package is built without OpenSSL support.
72 72
 endef
73 73
 
74
+ifeq ($(CONFIG_IPV6),y)
75
+	CONFIGURE_ARGS += \
76
+		--enable-ipv6
77
+endif
78
+
74 79
 ifeq ($(BUILD_VARIANT),ssl)
75 80
 	CONFIGURE_ARGS += \
76 81
 		--with-openssl="$(STAGING_DIR)/usr"
@@ -81,6 +86,14 @@ ifeq ($(BUILD_VARIANT),nossl)
81 86
 		--without-openssl
82 87
 endif
83 88
 
89
+# The test for HAVE_WORKING_GETADDRINFO fails
90
+# when cross-compiling.
91
+#
92
+define Build/Configure
93
+	$(call Build/Configure/Default)
94
+	$(SED) 's/\/\* #undef HAVE_WORKING_GETADDRINFO \*\//#define HAVE_WORKING_GETADDRINFO 1/' $(PKG_BUILD_DIR)/src/config.h
95
+endef
96
+
84 97
 define Package/ngircd/install
85 98
 	$(INSTALL_DIR) $(1)/usr/sbin
86 99
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ngircd $(1)/usr/sbin/