瀏覽代碼

Import libaudiofile from oldpackages

Ted Hess 10 年之前
父節點
當前提交
da4616cfb6
共有 2 個文件被更改,包括 90 次插入0 次删除
  1. 77
    0
      libs/libaudiofile/Makefile
  2. 13
    0
      libs/libaudiofile/patches/001-audiofile-config-libdirs.patch

+ 77
- 0
libs/libaudiofile/Makefile 查看文件

@@ -0,0 +1,77 @@
1
+#
2
+# Copyright (C) 2006-2010 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=audiofile
11
+PKG_VERSION:=0.2.7
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:= \
16
+	http://github.com/downloads/mpruett/audiofile/ \
17
+	http://www.68k.org/~michael/audiofile/
18
+PKG_MD5SUM:=a39be317a7b1971b408805dc5e371862
19
+
20
+PKG_FIXUP:=autoreconf
21
+PKG_INSTALL=1
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/libaudiofile
26
+  SECTION:=libs
27
+  CATEGORY:=Libraries
28
+  TITLE:=Audio File library
29
+  URL:=http://www.68k.org/~michael/audiofile/
30
+endef
31
+
32
+define Package/libaudiofile/description
33
+ The audiofile library allows the processing of audio data to and from audio
34
+ files of many common formats (currently AIFF, AIFF-C, WAVE, NeXT/Sun, BICS,
35
+ and raw data).
36
+endef
37
+
38
+CONFIGURE_ARGS+= \
39
+	--enable-shared \
40
+	--enable-static \
41
+	--with-build-cc="$(HOSTCC)" \
42
+
43
+TARGET_CFLAGS+= $(FPIC) -std=c99
44
+
45
+define Build/InstallDev
46
+	$(INSTALL_DIR) $(2)/bin
47
+	$(CP) \
48
+		$(PKG_INSTALL_DIR)/usr/bin/audiofile-config \
49
+		$(2)/bin/
50
+	$(SED) \
51
+		's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
52
+		$(2)/bin/audiofile-config
53
+
54
+	$(INSTALL_DIR) $(1)/usr/include
55
+	$(CP) \
56
+		$(PKG_INSTALL_DIR)/usr/include/{af_vfs,audiofile,aupvlist}.h \
57
+		$(1)/usr/include/
58
+
59
+	$(INSTALL_DIR) $(1)/usr/lib
60
+	$(CP) \
61
+		$(PKG_INSTALL_DIR)/usr/lib/libaudiofile.{la,a,so*} \
62
+		$(1)/usr/lib/
63
+
64
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
65
+	$(CP) \
66
+		$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/audiofile.pc \
67
+		$(1)/usr/lib/pkgconfig/
68
+endef
69
+
70
+define Package/libaudiofile/install
71
+	$(INSTALL_DIR) $(1)/usr/lib
72
+	$(CP) \
73
+		$(PKG_INSTALL_DIR)/usr/lib/libaudiofile.so.* \
74
+		$(1)/usr/lib/
75
+endef
76
+
77
+$(eval $(call BuildPackage,libaudiofile))

+ 13
- 0
libs/libaudiofile/patches/001-audiofile-config-libdirs.patch 查看文件

@@ -0,0 +1,13 @@
1
+--- a/audiofile-config.in
2
++++ b/audiofile-config.in
3
+@@ -45,7 +45,9 @@ while test $# -gt 0; do
4
+       echo $includes
5
+       ;;
6
+     --libs)
7
+-      libdirs=-L@libdir@
8
++      if test @libdir@ != /usr/libdir ; then
9
++        libdirs=-L@libdir@
10
++      fi
11
+       echo $libdirs -laudiofile -lm
12
+       ;;
13
+     *)