|
@@ -0,0 +1,48 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=simplejson
|
|
11
|
+PKG_VERSION:=3.6.5
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+PKG_LICENSE:=MIT
|
|
14
|
+
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
16
|
+PKG_SOURCE_URL:=http://pypi.python.org/packages/source/s/simplejson/
|
|
17
|
+PKG_MD5SUM:=b65dc21c7aaad14c6b4ad0d9179e437d
|
|
18
|
+PKG_BUILD_DEPENDS:=python python-setuptools
|
|
19
|
+
|
|
20
|
+include $(INCLUDE_DIR)/package.mk
|
|
21
|
+$(call include_mk, python-package.mk)
|
|
22
|
+
|
|
23
|
+define Package/simplejson
|
|
24
|
+ SUBMENU:=Python
|
|
25
|
+ SECTION:=lang
|
|
26
|
+ CATEGORY:=Languages
|
|
27
|
+ MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
|
|
28
|
+ TITLE:=Simple, fast, extensible JSON encoder/decoder for Python
|
|
29
|
+ URL:=http://simplejson.readthedocs.org/
|
|
30
|
+ DEPENDS:=+python
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/simplejson/description
|
|
34
|
+ Simple, fast, extensible JSON encoder/decoder for Python
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Build/Compile
|
|
38
|
+ $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+define Package/simplejson/install
|
|
42
|
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
|
|
43
|
+ $(CP) \
|
|
44
|
+ $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
|
|
45
|
+ $(1)$(PYTHON_PKG_DIR)
|
|
46
|
+endef
|
|
47
|
+
|
|
48
|
+$(eval $(call BuildPackage,simplejson))
|