|
@@ -0,0 +1,39 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PECL_NAME:=propro
|
|
11
|
+PECL_LONGNAME:=Property proxy
|
|
12
|
+
|
|
13
|
+PKG_VERSION:=1.0.0
|
|
14
|
+PKG_RELEASE:=1
|
|
15
|
+PKG_MD5SUM:=9c775035fd17c65f0162b7eb1b4f8564
|
|
16
|
+
|
|
17
|
+PKG_NAME:=php5-pecl-propro
|
|
18
|
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
|
|
19
|
+PKG_SOURCE_URL:=http://pecl.php.net/get/
|
|
20
|
+
|
|
21
|
+PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
|
22
|
+
|
|
23
|
+PKG_LICENSE:=BSD-3-Clause
|
|
24
|
+PKG_LICENSE_FILES:=LICENSE
|
|
25
|
+
|
|
26
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PECL_NAME)-$(PKG_VERSION)
|
|
27
|
+PKG_BUILD_PARALLEL:=1
|
|
28
|
+
|
|
29
|
+PKG_FIXUP:=autoreconf
|
|
30
|
+
|
|
31
|
+include $(INCLUDE_DIR)/package.mk
|
|
32
|
+include $(INCLUDE_DIR)/nls.mk
|
|
33
|
+include ../php5/pecl.mk
|
|
34
|
+
|
|
35
|
+CONFIGURE_ARGS+= \
|
|
36
|
+ --enable-propro
|
|
37
|
+
|
|
38
|
+$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME)))
|
|
39
|
+$(eval $(call BuildPackage,$(PKG_NAME)))
|