|
@@ -0,0 +1,69 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=gnupg
|
|
11
|
+PKG_VERSION:=1.4.18
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
|
|
16
|
+ ftp://ftp.gnupg.org/gcrypt/gnupg
|
|
17
|
+PKG_MD5SUM:=54db1be9588b11afbbdd8b82d4ea883a
|
|
18
|
+
|
|
19
|
+PKG_LICENSE:=GPL-3.0
|
|
20
|
+PKG_LICENSE_FILE:=COPYING
|
|
21
|
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
|
|
22
|
+
|
|
23
|
+PKG_INSTALL:=1
|
|
24
|
+
|
|
25
|
+include $(INCLUDE_DIR)/package.mk
|
|
26
|
+
|
|
27
|
+define Package/gnupg
|
|
28
|
+ SECTION:=utils
|
|
29
|
+ CATEGORY:=Utilities
|
|
30
|
+ DEPENDS:=+zlib +libncurses +libreadline
|
|
31
|
+ TITLE:=GNU privacy guard - a free PGP replacement
|
|
32
|
+ URL:=http://www.gnupg.org/
|
|
33
|
+endef
|
|
34
|
+
|
|
35
|
+define Package/gnupg/description
|
|
36
|
+ GnuPG is GNU's tool for secure communication and data storage.
|
|
37
|
+ It can be used to encrypt data and to create digital signatures.
|
|
38
|
+ It includes an advanced key management facility and is compliant
|
|
39
|
+ with the proposed OpenPGP Internet standard as described in RFC2440.
|
|
40
|
+ .
|
|
41
|
+ GnuPG does not use any patented algorithms so it cannot be compatible
|
|
42
|
+ with PGP2 because it uses IDEA (which is patented worldwide).
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+CONFIGURE_ARGS += \
|
|
46
|
+ --disable-rpath \
|
|
47
|
+ --disable-asm \
|
|
48
|
+ --disable-gnupg-iconv \
|
|
49
|
+ --disable-card-support \
|
|
50
|
+ --disable-agent-support \
|
|
51
|
+ --disable-bzip2 \
|
|
52
|
+ --disable-exec \
|
|
53
|
+ --disable-ldap \
|
|
54
|
+ --disable-hkp \
|
|
55
|
+ --disable-finger \
|
|
56
|
+ --disable-ftp \
|
|
57
|
+ --disable-dns-srv \
|
|
58
|
+ --enable-fake-curl \
|
|
59
|
+ --disable-regex \
|
|
60
|
+
|
|
61
|
+MAKE_FLAGS += \
|
|
62
|
+ SUBDIRS="m4 intl zlib util mpi cipher tools g10 keyserver ${checks}" \
|
|
63
|
+
|
|
64
|
+define Package/gnupg/install
|
|
65
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
66
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpg $(1)/usr/bin/
|
|
67
|
+endef
|
|
68
|
+
|
|
69
|
+$(eval $(call BuildPackage,gnupg))
|