|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=strongswan
|
11
|
11
|
PKG_VERSION:=5.2.1
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
15
|
15
|
PKG_SOURCE_URL:=http://download.strongswan.org/ http://download2.strongswan.org/
|
|
@@ -298,22 +298,16 @@ define BuildPlugin
|
298
|
298
|
DEPENDS:= +strongswan $(3)
|
299
|
299
|
endef
|
300
|
300
|
|
301
|
|
- strongswan_mod_conf=$(wildcard $(PKG_INSTALL_DIR)/etc/strongswan.d/charon/$(1).conf)
|
302
|
301
|
define Package/strongswan-mod-$(1)/install
|
303
|
302
|
$(INSTALL_DIR) $$(1)/etc/strongswan.d/charon
|
304
|
|
- $(if $(call strongswan_mod_conf,$(1)), \
|
305
|
|
- $(INSTALL_DATA) \
|
306
|
|
- $(call strongswan_mod_conf,$(1)) \
|
307
|
|
- $$(1)/etc/strongswan.d/charon/ \
|
308
|
|
- )
|
|
303
|
+ if [ -f $(PKG_INSTALL_DIR)/etc/strongswan.d/charon/$(1).conf ]; then \
|
|
304
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/strongswan.d/charon/$(1).conf $$(1)/etc/strongswan.d/charon/; fi
|
309
|
305
|
$(INSTALL_DIR) $$(1)/usr/lib/ipsec/plugins
|
310
|
306
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ipsec/plugins/libstrongswan-$(1).so \
|
311
|
307
|
$$(1)/usr/lib/ipsec/plugins/
|
312
|
308
|
$(call Plugin/$(1)/install,$$(1))
|
313
|
309
|
endef
|
314
|
310
|
|
315
|
|
- Package/strongswan-mod-$(1)/conffiles=$(patsubst $(PKG_INSTALL_DIR)%,%,$(call strongswan_mod_conf,$(1)))
|
316
|
|
-
|
317
|
311
|
$$(eval $$(call BuildPackage,strongswan-mod-$(1)))
|
318
|
312
|
endef
|
319
|
313
|
|