Browse Source

shairport-sync: update to v2.6

Closes https://github.com/openwrt/packages/pull/1869

Signed-off-by: Mike Brady <mikebrady@eircom.net>
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 9 years ago
parent
commit
dcb74ef849

+ 2
- 2
sound/shairport-sync/Makefile View File

@@ -9,8 +9,8 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=shairport-sync
12
-PKG_VERSION:=2.4.1
13
-PKG_RELEASE:=2
12
+PKG_VERSION:=2.6
13
+PKG_RELEASE:=1
14 14
 
15 15
 PKG_SOURCE_PROTO:=git
16 16
 PKG_SOURCE_URL:=git://github.com/mikebrady/shairport-sync.git

+ 1
- 0
sound/shairport-sync/files/shairport-sync.config View File

@@ -23,6 +23,7 @@ config shairport-sync 'shairport_sync'
23 23
 	option resync_threshold '' # 2205
24 24
 	option log_verbosity '' # 0/1/2/3
25 25
 	option ignore_volume_control '' # no/yes
26
+	option volume_range_db '' # 30 to 150
26 27
 	# Latencies
27 28
 	option latencies_default '' # 88200
28 29
 	option latencies_itunes '' # 99400

+ 1
- 0
sound/shairport-sync/files/shairport-sync.init View File

@@ -58,6 +58,7 @@ start_instance() {
58 58
 		append_num "$cfg" "$conf_file" resync_threshold "resync_threshold"
59 59
 		append_num "$cfg" "$conf_file" log_verbosity "log_verbosity"
60 60
 		append_str "$cfg" "$conf_file" ignore_volume_control "ignore_volume_control"
61
+		append_num "$cfg" "$conf_file" volume_range_db "volume_range_db"
61 62
 		echo -e "};\n" >> $conf_file
62 63
 
63 64
 		# Latencies