Browse Source

Merge pull request #1682 from ClaymorePT/master

boost: Boost Makefile Update to Version 1.59
Ted Hess 9 years ago
parent
commit
dd79bf0f49
2 changed files with 4 additions and 14 deletions
  1. 4
    3
      libs/boost/Makefile
  2. 0
    11
      libs/boost/patches/001-mips-options-fix.patch

+ 4
- 3
libs/boost/Makefile View File

@@ -16,14 +16,14 @@ include $(INCLUDE_DIR)/nls.mk
16 16
 include $(INCLUDE_DIR)/target.mk 
17 17
 
18 18
 PKG_NAME:=boost
19
-PKG_VERSION:=1_58_0
20
-PKG_RELEASE:=6
19
+PKG_VERSION:=1_59_0
20
+PKG_RELEASE:=1
21 21
 
22 22
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
23 23
 PKG_SOURCE_URL:=@SF/boost
24 24
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
25 25
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_VERSION)
26
-PKG_MD5SUM:=5a5d5614d9a07672e1ab2a250b5defc5
26
+PKG_MD5SUM:=51528a0e3b33d9e10aaa311d9eb451e3
27 27
 PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
28 28
 PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
29 29
 
@@ -109,6 +109,7 @@ define Package/boost-test
109 109
   $(call Package/boost/Default)
110 110
   TITLE+= (test)
111 111
   HIDDEN:=1  
112
+  DEPENDS+=+boost-system +boost-timer
112 113
 endef
113 114
 
114 115
 define Build/Configure

+ 0
- 11
libs/boost/patches/001-mips-options-fix.patch View File

@@ -1,11 +0,0 @@
1
---- boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:01:37.723438995 +0200
2
-+++ boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:00:21.427441384 +0200
3
-@@ -451,7 +451,7 @@
4
-         else
5
-         {
6
-             local arch = [ feature.get-values architecture : $(properties) ] ;
7
--            if $(arch) != arm
8
-+            if $(arch) = power || $(arch) = sparc || $(arch) = x86
9
-             {
10
-                 if $(model) = 32
11
-                 {