Browse Source

boost: do not fail when no shared libs were build

When only boost is selected without any specific boost library no *.so
file will be build and the InstallDev part is failing. Instead of
checking if there is a lib directory just try to copy the libs and do
not fail in case of an error.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Hauke Mehrtens 9 years ago
parent
commit
dd7b5a4240
1 changed files with 3 additions and 10 deletions
  1. 3
    10
      libs/boost/Makefile

+ 3
- 10
libs/boost/Makefile View File

@@ -226,16 +226,9 @@ define Build/InstallDev
226 226
 		$(1)/usr/include/boost/ \
227 227
 		# copies _all_ header files - independent of <--with-library>-argument above
228 228
 
229
-	if [ -d $(PKG_INSTALL_DIR)/lib ]; then \
230
-		$(INSTALL_DIR) \
231
-			$(1)/usr/lib; \
232
-		$(CP) \
233
-			$(PKG_INSTALL_DIR)/lib/*.a \
234
-			$(1)/usr/lib/; \
235
-		$(CP) \
236
-			$(PKG_INSTALL_DIR)/lib/*.so* \
237
-			$(1)/usr/lib/; \
238
-	fi
229
+	$(INSTALL_DIR) $(1)/usr/lib
230
+	-$(CP) $(PKG_INSTALL_DIR)/lib/*.a $(1)/usr/lib/
231
+	-$(CP) $(PKG_INSTALL_DIR)/lib/*.so* $(1)/usr/lib/
239 232
 endef
240 233
 
241 234
 define Host/Install