Browse Source

nail: unbreak compilation

disabling SSLv2 and SSLv3 caused nail to break, fixed this
some of our snapshot builders don't have CVS, switch to Debian as source

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 10 years ago
parent
commit
de0ab1305e
2 changed files with 21 additions and 6 deletions
  1. 5
    6
      mail/nail/Makefile
  2. 16
    0
      mail/nail/patches/100-handle-openssl-without-sslv2.patch

+ 5
- 6
mail/nail/Makefile View File

@@ -8,15 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=nail
11
-PKG_VERSION:=
11
+PKG_VERSION:=12.5
12 12
 PKG_RELEASE:=1
13 13
 PKG_LICENSE:=BSD-2-Clause
14 14
 
15
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
16
-PKG_SOURCE_URL:=:pserver:anonymous@nail.cvs.sourceforge.net:/cvsroot/nail
17
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)
18
-PKG_SOURCE_VERSION:=-D"2014-11-24 00:00"
19
-PKG_SOURCE_PROTO:=cvs
15
+PKG_SOURCE:=heirloom-mailx_$(PKG_VERSION).orig.tar.gz
16
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/h/heirloom-mailx/
17
+PKG_MD5SUM:=29a6033ef1412824d02eb9d9213cb1f2
18
+PKG_BUILD_DIR:=$(BUILD_DIR)/heirloom-mailx-$(PKG_VERSION)
20 19
 
21 20
 PKG_INSTALL:=0
22 21
 

+ 16
- 0
mail/nail/patches/100-handle-openssl-without-sslv2.patch View File

@@ -0,0 +1,16 @@
1
+--- a/openssl.c
2
++++ b/openssl.c
3
+@@ -216,9 +216,12 @@ ssl_select_method(const char *uhp)
4
+ 
5
+ 	cp = ssl_method_string(uhp);
6
+ 	if (cp != NULL) {
7
++#ifndef OPENSSL_NO_SSL2
8
+ 		if (equal(cp, "ssl2"))
9
+ 			method = SSLv2_client_method();
10
+-		else if (equal(cp, "ssl3"))
11
++		else
12
++#endif
13
++		if (equal(cp, "ssl3"))
14
+ 			method = SSLv3_client_method();
15
+ 		else if (equal(cp, "tls1"))
16
+ 			method = TLSv1_client_method();