Browse Source

ibrdtn-tools: Updated to 1.0.0

Signed-off-by: Johannes Morgenroth <jm@m-network.de>
Johannes Morgenroth 10 years ago
parent
commit
df34963277

+ 3
- 4
net/ibrdtn-tools/Makefile View File

@@ -8,17 +8,16 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ibrdtn-tools
11
-PKG_VERSION:=0.12.1
11
+PKG_VERSION:=1.0.0
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
16
-PKG_MD5SUM:=0ce0c6e754263919ad48661967c2f6fd
17
-PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
16
+PKG_MD5SUM:=ec522079278bcdf4181e6a1d86f8d72f
17
+PKG_MAINTAINER:=Johannes Morgenroth <jm@m-network.de>
18 18
 PKG_LICENSE:=Apache-2.0
19 19
 
20 20
 PKG_INSTALL:=1
21
-PKG_FIXUP:=autoreconf
22 21
 
23 22
 include $(INCLUDE_DIR)/package.mk
24 23
 

+ 0
- 88
net/ibrdtn-tools/patches/100-add_configure_options.patch View File

@@ -1,89 +0,0 @@
1
---- a/configure.ac
2
-+++ b/configure.ac
3
-@@ -67,34 +67,57 @@ AC_TYPE_UINT8_T
4
- AC_FUNC_MALLOC
5
- AC_CHECK_FUNCS([memset])
6
- 
7
--PKG_CHECK_MODULES(DAEMON, libdaemon >= 0.12, [
8
--	AC_SUBST(DAEMON_CFLAGS)
9
--	AC_SUBST(DAEMON_LIBS)
10
--	AC_DEFINE(HAVE_LIBDAEMON, [1], ["daemon library is available"])
11
--	AC_CHECK_LIB(daemon, daemon_reset_sigs, [
12
--		AC_DEFINE(HAVE_DAEMON_RESET_SIGS, [1], ["daemon library has daemon_reset_sigs() and daemon_unblock_sigs() functions"])
13
--	])
14
--], [
15
--	AC_MSG_WARN([daemon library not found, daemonize features disabled])
16
--])
17
-+AC_ARG_WITH([libdaemon],
18
-+	AS_HELP_STRING([--without-libdaemon], [Build without daemonize support]),
19
-+	[
20
-+		AC_MSG_NOTICE([daemonize support disabled])
21
-+	], [
22
-+		PKG_CHECK_MODULES(DAEMON, libdaemon >= 0.12, [
23
-+			AC_SUBST(DAEMON_CFLAGS)
24
-+			AC_SUBST(DAEMON_LIBS)
25
-+			AC_DEFINE(HAVE_LIBDAEMON, [1], ["daemon library is available"])
26
-+			AC_CHECK_LIB(daemon, daemon_reset_sigs, [
27
-+				AC_DEFINE(HAVE_DAEMON_RESET_SIGS, [1], ["daemon library has daemon_reset_sigs() and daemon_unblock_sigs() functions"])
28
-+			])
29
-+		], [
30
-+			AC_MSG_WARN([daemon library not found, daemonize features disabled])
31
-+		])
32
-+	]
33
-+)
34
- 
35
--PKG_CHECK_MODULES(ARCHIVE, libarchive >= 3.0, [
36
--	AC_SUBST(ARCHIVE_CFLAGS)
37
--	AC_SUBST(ARCHIVE_LIBS)
38
--	AC_DEFINE(HAVE_LIBARCHIVE, [1], ["libarchive is available"])
39
--		has_libarchive="yes"
40
--], [
41
--	AC_MSG_WARN([libarchive not found, dtninbox and dtnoutbox will not be compiled])
42
--])
43
-+AC_ARG_WITH([libarchive],
44
-+	AS_HELP_STRING([--without-libarchive], [Build without archive support]),
45
-+	[
46
-+		has_libarchive="no"
47
-+		AC_MSG_NOTICE([archive support disabled, dtninbox and dtnoutbox will not be compiled])
48
-+	], [
49
-+		PKG_CHECK_MODULES(ARCHIVE, libarchive >= 3.0, [
50
-+			AC_SUBST(ARCHIVE_CFLAGS)
51
-+			AC_SUBST(ARCHIVE_LIBS)
52
-+			AC_DEFINE(HAVE_LIBARCHIVE, [1], ["libarchive is available"])
53
-+				has_libarchive="yes"
54
-+		], [
55
-+			AC_MSG_WARN([libarchive not found, dtninbox and dtnoutbox will not be compiled])
56
-+		])
57
-+	]
58
-+)
59
- 
60
--PKG_CHECK_MODULES(OPENSSL, openssl, [
61
--	AC_SUBST(OPENSSL_CFLAGS)
62
--	AC_SUBST(OPENSSL_LIBS)
63
--	AC_DEFINE(HAVE_OPENSSL, [1], ["openssl available"])
64
--		has_openssl="yes"
65
--], [
66
--	AC_MSG_WARN([openssl not found, dtninbox and dtnoutbox will not be compiled])
67
--])
68
-+AC_ARG_WITH([openssl],
69
-+	AS_HELP_STRING([--without-openssl], [Build without openssl support]),
70
-+	[
71
-+		has_openssl="no"
72
-+		AC_MSG_NOTICE([openssl support disabled, dtninbox and dtnoutbox will not be compiled])
73
-+	], [
74
-+		PKG_CHECK_MODULES(OPENSSL, openssl, [
75
-+			AC_SUBST(OPENSSL_CFLAGS)
76
-+			AC_SUBST(OPENSSL_LIBS)
77
-+			AC_DEFINE(HAVE_OPENSSL, [1], ["openssl available"])
78
-+				has_openssl="yes"
79
-+		], [
80
-+			AC_MSG_WARN([openssl not found, dtninbox and dtnoutbox will not be compiled])
81
-+		])
82
-+	]
83
-+)
84
- 
85
- AC_ARG_WITH([tffs],
86
- AS_HELP_STRING([--with-tffs=PATH], [set the tffs path for fat-image support in dtnoutbox]), [
87
-1.9.1
88
-