Browse Source

lxc: correctly install configuration files

Signed-off-by: Luka Perkov <luka@openwrt.org>
Luka Perkov 10 years ago
parent
commit
dfd4daf633
3 changed files with 6 additions and 5 deletions
  1. 5
    0
      utils/lxc/Makefile
  2. 1
    0
      utils/lxc/files/lxc.conf
  3. 0
    5
      utils/lxc/patches/100-lxc-defconfig.patch

+ 5
- 0
utils/lxc/Makefile View File

@@ -165,6 +165,11 @@ define Package/lxc-common/install
165 165
 	$(INSTALL_DIR) $(1)/etc/lxc/
166 166
 	$(CP) \
167 167
 		$(PKG_INSTALL_DIR)/etc/lxc/default.conf \
168
+		$(1)/etc/lxc/default.conf
169
+
170
+	$(INSTALL_DIR) $(1)/etc/lxc/
171
+	$(CP) \
172
+		./files/lxc.conf \
168 173
 		$(1)/etc/lxc/lxc.conf
169 174
 
170 175
 	$(INSTALL_DIR) $(1)/lxc/

+ 1
- 0
utils/lxc/files/lxc.conf View File

@@ -0,0 +1 @@
1
+lxc.lxcpath = /lxc

+ 0
- 5
utils/lxc/patches/100-lxc-defconfig.patch View File

@@ -1,5 +0,0 @@
1
---- a/config/etc/default.conf.unknown
2
-+++ b/config/etc/default.conf.unknown
3
-@@ -1 +1,2 @@
4
-+lxc.lxcpath = /lxc
5
- lxc.network.type = empty