|
@@ -1,41 +0,0 @@
|
1
|
|
-From 36fd4f214f9ba74aaf0e5fb3e4ba271b946a1550 Mon Sep 17 00:00:00 2001
|
2
|
|
-From: Thomas Graf <tgraf@noironetworks.com>
|
3
|
|
-Date: Wed, 26 Nov 2014 15:52:31 +0100
|
4
|
|
-Subject: [PATCH] datapath: Use ccflags-y instead of deprecated EXTRA_CFLAGS
|
5
|
|
-
|
6
|
|
-This allows users to pass in additional compiler flags through the
|
7
|
|
-environment variable EXTRA_CFLAGS, e.g.
|
8
|
|
-
|
9
|
|
- make EXTRA_CFLAGS=-Wno-error=foo V=1
|
10
|
|
-
|
11
|
|
-Reported-by: Alexandru Ardelean <ardeleanalex@gmail.com>
|
12
|
|
-Signed-off-by: Thomas Graf <tgraf@noironetworks.com>
|
13
|
|
-Acked-by: Pravin B Shelar <pshelar@nicira.com>
|
14
|
|
----
|
15
|
|
- datapath/linux/Kbuild.in | 10 +++++-----
|
16
|
|
- 1 file changed, 5 insertions(+), 5 deletions(-)
|
17
|
|
-
|
18
|
|
-diff --git a/datapath/linux/Kbuild.in b/datapath/linux/Kbuild.in
|
19
|
|
-index 6f6f65f..cb98c11 100644
|
20
|
|
---- a/datapath/linux/Kbuild.in
|
21
|
|
-+++ b/datapath/linux/Kbuild.in
|
22
|
|
-@@ -7,11 +7,11 @@ export VERSION = @VERSION@
|
23
|
|
- include $(srcdir)/../Modules.mk
|
24
|
|
- include $(srcdir)/Modules.mk
|
25
|
|
-
|
26
|
|
--EXTRA_CFLAGS := -DVERSION=\"$(VERSION)\"
|
27
|
|
--EXTRA_CFLAGS += -I$(srcdir)/..
|
28
|
|
--EXTRA_CFLAGS += -I$(builddir)/..
|
29
|
|
--EXTRA_CFLAGS += -g
|
30
|
|
--EXTRA_CFLAGS += -include $(builddir)/kcompat.h
|
31
|
|
-+ccflags-y := -DVERSION=\"$(VERSION)\"
|
32
|
|
-+ccflags-y += -I$(srcdir)/..
|
33
|
|
-+ccflags-y += -I$(builddir)/..
|
34
|
|
-+ccflags-y += -g
|
35
|
|
-+ccflags-y += -include $(builddir)/kcompat.h
|
36
|
|
-
|
37
|
|
- # These include directories have to go before -I$(KSRC)/include.
|
38
|
|
- # NOSTDINC_FLAGS just happens to be a variable that goes in the
|
39
|
|
-2.1.2
|
40
|
|
-
|