Преглед изворни кода

openvswitch: upgrade to version 2.3.90

Emanuele Bovisio пре 10 година
родитељ
комит
dfd640394c

+ 6
- 6
net/openvswitch/Makefile Прегледај датотеку

@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
12 12
 PKG_NAME:=openvswitch
13 13
 
14 14
 PKG_RELEASE:=2
15
-PKG_VERSION:=2.3.1
15
+PKG_VERSION:=2.3.90
16 16
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
17 17
 PKG_LICENSE:=Apache-2.0
18 18
 PKG_LICENSE_FILES:=COPYING
@@ -21,7 +21,7 @@ PKG_USE_MIPS16:=0
21 21
 PKG_SOURCE_PROTO:=git
22 22
 PKG_SOURCE_URL:=https://github.com/openvswitch/ovs
23 23
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
24
-PKG_SOURCE_VERSION:=0dfed4ba9c8a16a1f316d709b7831a4e139472d4
24
+PKG_SOURCE_VERSION:=58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d
25 25
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
26 26
 
27 27
 include $(INCLUDE_DIR)/package.mk
@@ -149,10 +149,10 @@ define Package/openvswitch/install
149 149
 	$(INSTALL_BIN) ./files/etc/init.d/openvswitch.init $(1)/etc/init.d/openvswitch
150 150
 
151 151
 	$(INSTALL_DIR) $(1)/usr/lib/
152
-	$(CP) $(PKG_BUILD_DIR)/lib/.libs/libsflow-$(PKG_VERSION).so  $(1)/usr/lib/
153
-	$(CP) $(PKG_BUILD_DIR)/lib/.libs/libopenvswitch-$(PKG_VERSION).so  $(1)/usr/lib/
154
-	$(CP) $(PKG_BUILD_DIR)/ofproto/.libs/libofproto-$(PKG_VERSION).so  $(1)/usr/lib/
155
-	$(CP) $(PKG_BUILD_DIR)/ovsdb/.libs/libovsdb-$(PKG_VERSION).so  $(1)/usr/lib/
152
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/libsflow.so*  $(1)/usr/lib/
153
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/libopenvswitch.so*  $(1)/usr/lib/
154
+	$(CP) $(PKG_BUILD_DIR)/ofproto/.libs/libofproto.so*  $(1)/usr/lib/
155
+	$(CP) $(PKG_BUILD_DIR)/ovsdb/.libs/libovsdb.so*  $(1)/usr/lib/
156 156
 
157 157
 	$(INSTALL_DIR) $(1)/usr/bin/
158 158
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-appctl $(1)/usr/bin/

net/openvswitch/patches/0002-netdev-linux-Use-unsigned-int-for-ifi_flags.patch → net/openvswitch/patches/0001-netdev-linux-Use-unsigned-int-for-ifi_flags.patch Прегледај датотеку

@@ -14,7 +14,7 @@ diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
14 14
 index 9bdbbdf..9eaac33 100644
15 15
 --- a/lib/netdev-linux.c
16 16
 +++ b/lib/netdev-linux.c
17
-@@ -2566,7 +2566,7 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
17
+@@ -2709,7 +2709,7 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
18 18
               enum netdev_flags on, enum netdev_flags *old_flagsp)
19 19
      OVS_REQUIRES(netdev->mutex)
20 20
  {

net/openvswitch/patches/0001-netdev-linux-Let-interface-flag-survive-internal-por.patch → net/openvswitch/patches/0002-netdev-linux-Let-interface-flag-survive-internal-por.patch Прегледај датотеку

@@ -21,7 +21,7 @@ diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
21 21
 index 9eaac33..423e72e 100644
22 22
 --- a/lib/netdev-linux.c
23 23
 +++ b/lib/netdev-linux.c
24
-@@ -2569,7 +2569,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
24
+@@ -2712,7 +2712,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
25 25
      unsigned int old_flags, new_flags;
26 26
      int error = 0;
27 27
  

+ 0
- 35
net/openvswitch/patches/0003-lib-util.h-Disable-ovs_assert-when-build-with-NDEBUG.patch Прегледај датотеку

@@ -1,36 +0,0 @@
1
-From 34b51e26555d05c00b2320f943a645added5dae4 Mon Sep 17 00:00:00 2001
2
-From: Helmut Schaa <helmut.schaa@googlemail.com>
3
-Date: Mon, 9 Dec 2013 14:15:11 +0100
4
-Subject: [PATCH 5/6] lib/util.h: Disable ovs_assert when build with NDEBUG
5
-
6
-Reduces binary size. Use a static inline function instead of
7
-a macro to not get "unused variable" warning everywhere.
8
-
9
-Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
10
----
11
- lib/util.h | 5 +++++
12
- 1 file changed, 5 insertions(+)
13
-
14
-diff --git a/lib/util.h b/lib/util.h
15
-index 5c23962..9e5866d 100644
16
---- a/lib/util.h
17
-+++ b/lib/util.h
18
-@@ -69,10 +69,15 @@
19
-  *   - Writes the failure message to the log.
20
-  *
21
-  *   - Not affected by NDEBUG. */
22
-+#ifndef NDEBUG
23
- #define ovs_assert(CONDITION)                                           \
24
-     if (!OVS_LIKELY(CONDITION)) {                                       \
25
-         ovs_assert_failure(SOURCE_LOCATOR, __func__, #CONDITION);       \
26
-     }
27
-+#else
28
-+static inline void ovs_assert(bool cond OVS_UNUSED) {}
29
-+#endif
30
-+
31
- void ovs_assert_failure(const char *, const char *, const char *) NO_RETURN;
32
- 
33
- /* Casts 'pointer' to 'type' and issues a compiler warning if the cast changes
34
-1.8.1.4
35
-

+ 0
- 40
net/openvswitch/patches/0004-datapath-Use-ccflags-y-instead-of-deprecated-EXTRA_C.patch Прегледај датотеку

@@ -1,41 +0,0 @@
1
-From 36fd4f214f9ba74aaf0e5fb3e4ba271b946a1550 Mon Sep 17 00:00:00 2001
2
-From: Thomas Graf <tgraf@noironetworks.com>
3
-Date: Wed, 26 Nov 2014 15:52:31 +0100
4
-Subject: [PATCH] datapath: Use ccflags-y instead of deprecated EXTRA_CFLAGS
5
-
6
-This allows users to pass in additional compiler flags through the
7
-environment variable EXTRA_CFLAGS, e.g.
8
-
9
-   make EXTRA_CFLAGS=-Wno-error=foo V=1
10
-
11
-Reported-by: Alexandru Ardelean <ardeleanalex@gmail.com>
12
-Signed-off-by: Thomas Graf <tgraf@noironetworks.com>
13
-Acked-by: Pravin B Shelar <pshelar@nicira.com>
14
----
15
- datapath/linux/Kbuild.in | 10 +++++-----
16
- 1 file changed, 5 insertions(+), 5 deletions(-)
17
-
18
-diff --git a/datapath/linux/Kbuild.in b/datapath/linux/Kbuild.in
19
-index 6f6f65f..cb98c11 100644
20
---- a/datapath/linux/Kbuild.in
21
-+++ b/datapath/linux/Kbuild.in
22
-@@ -7,11 +7,11 @@ export VERSION = @VERSION@
23
- include $(srcdir)/../Modules.mk
24
- include $(srcdir)/Modules.mk
25
- 
26
--EXTRA_CFLAGS := -DVERSION=\"$(VERSION)\"
27
--EXTRA_CFLAGS += -I$(srcdir)/..
28
--EXTRA_CFLAGS += -I$(builddir)/..
29
--EXTRA_CFLAGS += -g
30
--EXTRA_CFLAGS += -include $(builddir)/kcompat.h
31
-+ccflags-y := -DVERSION=\"$(VERSION)\"
32
-+ccflags-y += -I$(srcdir)/..
33
-+ccflags-y += -I$(builddir)/..
34
-+ccflags-y += -g
35
-+ccflags-y += -include $(builddir)/kcompat.h
36
- 
37
- # These include directories have to go before -I$(KSRC)/include.
38
- # NOSTDINC_FLAGS just happens to be a variable that goes in the
39
-2.1.2
40
-