Browse Source

xl2tpd: fix xl2tpd options

The previous commit left an unwanted string in the options passed
to xl2tpd-control. Remove that as well.
Also set procd respawn parameter now that I'm at it.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 years ago
parent
commit
e0b2a226a3
3 changed files with 3 additions and 2 deletions
  1. 1
    1
      net/xl2tpd/Makefile
  2. 1
    1
      net/xl2tpd/files/l2tp.sh
  3. 1
    0
      net/xl2tpd/files/xl2tpd.init

+ 1
- 1
net/xl2tpd/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=xl2tpd
11 11
 PKG_VERSION:=1.3.7pre20150524
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
14 14
 PKG_LICENSE:=GPL-2.0
15 15
 PKG_LICENSE_FILES:=LICENSE

+ 1
- 1
net/xl2tpd/files/l2tp.sh View File

@@ -86,7 +86,7 @@ proto_l2tp_setup() {
86 86
 	echo "${ipv6:++ipv6} ${pppd_options}" >> "${optfile}"
87 87
 	echo "${mtu:+mtu $mtu mru $mtu}" >> "${optfile}"
88 88
 
89
-	xl2tpd-control add l2tp-${interface} pppoptfile=${optfile} lns=${server} timeout=20 || {
89
+	xl2tpd-control add l2tp-${interface} pppoptfile=${optfile} lns=${server} || {
90 90
 		echo "xl2tpd-control: Add l2tp-$interface failed" >&2
91 91
 		proto_setup_failed "$interface"
92 92
 		exit 1

+ 1
- 0
net/xl2tpd/files/xl2tpd.init View File

@@ -14,6 +14,7 @@ start_service() {
14 14
 
15 15
 	procd_open_instance
16 16
 	procd_set_param command $BIN -D -l -p "$PID_F"
17
+	procd_set_param respawn
17 18
 	procd_close_instance
18 19
 }
19 20