Browse Source

Merge pull request #1405 from jow-/zabbix-musl-compat

zabbix: fix musl compatibility
Jo-Philipp Wich 9 years ago
parent
commit
e0f8adcb0a
2 changed files with 25 additions and 2 deletions
  1. 2
    2
      admin/zabbix/Makefile
  2. 23
    0
      admin/zabbix/patches/100-musl-compat.patch

+ 2
- 2
admin/zabbix/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=zabbix
11 11
 PKG_VERSION:=2.4.5
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/zabbix

+ 23
- 0
admin/zabbix/patches/100-musl-compat.patch View File

@@ -0,0 +1,23 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -51,7 +51,7 @@ AC_CHECK_HEADERS(stdio.h stdlib.h string
4
+   syslog.h time.h errno.h sys/types.h sys/stat.h netinet/in.h \
5
+   math.h sys/socket.h dirent.h ctype.h \
6
+   mtent.h fcntl.h sys/param.h arpa/inet.h \
7
+-  sys/vfs.h sys/pstat.h sys/sysinfo.h sys/statvfs.h sys/statfs.h \
8
++  sys/vfs.h sys/pstat.h sys/statvfs.h sys/statfs.h \
9
+   sys/socket.h sys/loadavg.h arpa/inet.h \
10
+   sys/vmmeter.h strings.h vm/vm_param.h \
11
+   sys/time.h kstat.h sys/syscall.h sys/sysmacros.h \
12
+@@ -63,6 +63,11 @@ AC_CHECK_HEADERS(stdio.h stdlib.h string
13
+   sys/timeb.h Winber.h lber.h ws2tcpip.h inttypes.h sys/file.h grp.h \
14
+   execinfo.h libperfstat.h sys/systemcfg.h sys/mnttab.h mntent.h sys/times.h \
15
+   dlfcn.h sys/utsname.h)
16
++AC_CHECK_HEADERS(sys/sysinfo.h, [], [], [
17
++#ifdef HAVE_LINUX_KERNEL_H
18
++#  include <linux/kernel.h>
19
++#endif
20
++])
21
+ AC_CHECK_HEADERS(resolv.h, [], [], [
22
+ #ifdef HAVE_SYS_TYPES_H
23
+ #  include <sys/types.h>