Browse Source

ntripclient: fix musl comaptibility

Add missing `sys/select.h` include to `ntripclient.c` to provide
declarations for `struct timeval` and `fd_set` under musl.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 years ago
parent
commit
e10abaf165
2 changed files with 13 additions and 2 deletions
  1. 3
    2
      net/ntripclient/Makefile
  2. 10
    0
      net/ntripclient/patches/100-musl-compat.patch

+ 3
- 2
net/ntripclient/Makefile View File

@@ -1,6 +1,6 @@
1 1
 #
2 2
 # Copyright (C) 2011 segal.ubi.pt
3
-# Copyright (C) 2010-2014 OpenWrt.org
3
+# Copyright (C) 2010-2015 OpenWrt.org
4 4
 #
5 5
 # This is free software, licensed under the GNU General Public License v2.
6 6
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=ntripclient
12 12
 PKG_VERSION:=1.5.0
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=3
14 14
 PKG_LICENSE:=GPL-2.0+
15 15
 
16 16
 PKG_SOURCE:=$(PKG_NAME).zip
@@ -36,6 +36,7 @@ endef
36 36
 define Build/Prepare
37 37
 	mkdir -p $(PKG_BUILD_DIR)
38 38
 	unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR)
39
+	$(call Build/Prepare/Default)
39 40
 endef
40 41
 
41 42
 MAKE_FLAGS += \

+ 10
- 0
net/ntripclient/patches/100-musl-compat.patch View File

@@ -0,0 +1,10 @@
1
+--- a/ntripclient.c
2
++++ b/ntripclient.c
3
+@@ -44,6 +44,7 @@
4
+   #include <fcntl.h>
5
+   #include <unistd.h>
6
+   #include <arpa/inet.h>
7
++  #include <sys/select.h>
8
+   #include <sys/socket.h>
9
+   #include <netinet/in.h>
10
+   #include <netdb.h>