Browse Source

devel/libtool-bin: new package

GNU libtool is used to ease the usage of shared libraries in Makefiles.

The new package libtool-bin contains the script libtoolize which is used
to prepare a package to use libtool.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
Heinrich Schuchardt 9 years ago
parent
commit
e207730a64
1 changed files with 51 additions and 0 deletions
  1. 51
    0
      devel/libtool-bin/Makefile

+ 51
- 0
devel/libtool-bin/Makefile View File

@@ -0,0 +1,51 @@
1
+#
2
+# Copyright (C) 2016 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libtool
11
+PKG_VERSION:=2.4.6
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=@GNU/libtool
16
+PKG_MD5SUM:=addf44b646ddb4e3919805aa88fa7c5e
17
+PKG_MAINTAINER:=Heinrich Schuchardt <xypron.glpk@gmx.de>
18
+PKG_LICENSE:=GPL-2.0+
19
+PKG_BUILD_DIR = $(BUILD_DIR)/libtool-bin/$(PKG_NAME)-$(PKG_VERSION)
20
+
21
+PKG_INSTALL:=1
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/libtool-bin
26
+  SECTION:=devel
27
+  CATEGORY:=Development
28
+  TITLE:=GNU Libtool - libtoolize
29
+  URL:=https://www.gnu.org/software/libtool/
30
+endef
31
+
32
+define Package/libtool-bin/description
33
+ GNU libtool is a generic library support script.
34
+ Libtool hides the complexity of using shared libraries behind a consistent,
35
+ portable interface. 
36
+ This package contains the libtoolize executable.
37
+endef
38
+
39
+define Package/libtool-bin/install
40
+	$(INSTALL_DIR) $(1)/usr/bin
41
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libtoolize $(1)/usr/bin/
42
+	$(SED) 's|$(STAGING_DIR_HOST)||g' $(1)/usr/bin/libtoolize
43
+	$(INSTALL_DIR) $(1)/usr/share/aclocal/
44
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/*.m4 \
45
+	  $(1)/usr/share/aclocal/
46
+	$(INSTALL_DIR) $(1)/usr/share/libtool/build-aux/
47
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/libtool/build-aux/* \
48
+	  $(1)/usr/share/libtool/build-aux/
49
+endef
50
+
51
+$(eval $(call BuildPackage,libtool-bin))