Browse Source

collectd: backport parallel build fix from upstream

Backport a fix for parallel build from upstream,
where it has been commited to both trunk and 5.5 branch.

https://github.com/collectd/collectd/issues/1146
780e6a7602

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Hannu Nyman 9 years ago
parent
commit
e2699e23f6
1 changed files with 17 additions and 0 deletions
  1. 17
    0
      utils/collectd/patches/500-upstream-parallel-build-fix.patch

+ 17
- 0
utils/collectd/patches/500-upstream-parallel-build-fix.patch View File

@@ -0,0 +1,17 @@
1
+Backport of 780e6a76021a240e95007a04b723d827120afa95
2
+Subject: [PATCH] build: add libavltree, libcommon & libheap dependencies
3
+
4
+Otherwise it can break on very parallel builds since collectd link time
5
+arrives before one or more of these were built.
6
+
7
+--- a/src/daemon/Makefile.am
8
++++ b/src/daemon/Makefile.am
9
+@@ -49,7 +49,7 @@ collectd_CPPFLAGS =  $(AM_CPPFLAGS) $(LT
10
+ collectd_CFLAGS = $(AM_CFLAGS)
11
+ collectd_LDFLAGS = -export-dynamic
12
+ collectd_LDADD = libavltree.la libcommon.la libheap.la -lm
13
+-collectd_DEPENDENCIES =
14
++collectd_DEPENDENCIES = libavltree.la libcommon.la libheap.la
15
+ 
16
+ # Link to these libraries..
17
+ if BUILD_WITH_LIBRT