Browse Source

Copy libmcrypt from old repository and update

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 10 years ago
parent
commit
e2e0b211e5
1 changed files with 65 additions and 0 deletions
  1. 65
    0
      libs/libmcrypt/Makefile

+ 65
- 0
libs/libmcrypt/Makefile View File

@@ -0,0 +1,65 @@
1
+#
2
+# Copyright (C) 2006-2010 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libmcrypt
11
+PKG_VERSION:=2.5.8
12
+PKG_RELEASE:=2
13
+
14
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15
+
16
+PKG_LICENSE:=LGPLv2.1
17
+PKG_LICENSE_FILE:=COPYING.LIB
18
+
19
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
20
+PKG_SOURCE_URL:=@SF/mcrypt
21
+PKG_MD5SUM:=c4f491dd411a09e9de3b8702ea6f73eb
22
+
23
+PKG_FIXUP:=autoreconf
24
+PKG_INSTALL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+TARGET_CFLAGS += $(FPIC)
29
+
30
+define Package/libmcrypt
31
+  SECTION:=libs
32
+  CATEGORY:=Libraries
33
+  TITLE:=Cryptographic library
34
+  URL:=http://mcrypt.sourceforge.net/
35
+endef
36
+
37
+define Package/libmcrypt/description
38
+	libmcrypt is a cryptographic library that conveniently brings
39
+	together a variety of ciphers for convenient use.
40
+endef
41
+
42
+define Build/Configure
43
+	$(call Build/Configure/Default, \
44
+		--enable-shared \
45
+		--enable-static \
46
+	)
47
+endef
48
+
49
+define Build/InstallDev
50
+	$(INSTALL_DIR) $(1)/usr/include
51
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
52
+	$(INSTALL_DIR) $(1)/usr/lib
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libmcrypt.{a,so*} $(1)/usr/lib/
54
+	$(INSTALL_DIR) $(1)/usr/bin
55
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libmcrypt-config $(1)/usr/bin/
56
+	$(SED) 's,-I$$$${prefix}/include,,g' $(1)/usr/bin/libmcrypt-config
57
+	$(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/libmcrypt-config
58
+endef
59
+
60
+define Package/libmcrypt/install
61
+	$(INSTALL_DIR) $(1)/usr/lib
62
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libmcrypt.so.* $(1)/usr/lib/
63
+endef
64
+
65
+$(eval $(call BuildPackage,libmcrypt))