|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2007-2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2007-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
include $(INCLUDE_DIR)/kernel.mk
|
10
|
10
|
|
11
|
11
|
PKG_NAME:=lsof
|
12
|
|
-PKG_VERSION:=4.86
|
13
|
|
-PKG_RELEASE:=3
|
|
12
|
+PKG_VERSION:=4.89
|
|
13
|
+PKG_RELEASE:=1
|
14
|
14
|
|
15
|
|
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)+dfsg.orig.tar.gz
|
16
|
|
-PKG_SOURCE_URL:=http://ftp2.de.debian.org/debian/pool/main/l/lsof
|
17
|
|
-PKG_MD5SUM:=23420509564a897b76055f9d84d19068
|
18
|
|
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)+dfsg.orig
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.bz2
|
|
16
|
+PKG_SOURCE_URL:=https://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/ ftp://sunsite.ualberta.ca/pub/Mirror/lsof/ ftp://ftp.fu-berlin.de/pub/unix/tools/lsof
|
|
17
|
+PKG_MD5SUM:=1b9cd34f3fb86856a125abbf2be3a386
|
|
18
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
|
19
|
19
|
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
|
20
|
20
|
PKG_LICENSE:=Unique
|
21
|
21
|
PKG_LICENSE_FILES:=00README
|
|
@@ -32,17 +32,22 @@ define Package/lsof
|
32
|
32
|
URL:=http://people.freebsd.org/~abe/
|
33
|
33
|
endef
|
34
|
34
|
|
35
|
|
-ifeq ($(CONFIG_IPV6),y)
|
36
|
|
- LINUX_CLIB_IPV6="-DHASIPv6"
|
|
35
|
+ifneq ($(CONFIG_IPV6),n)
|
|
36
|
+ LINUX_CLIB_IPV6=-DHASIPv6
|
37
|
37
|
else
|
38
|
38
|
LINUX_CLIB_IPV6=
|
39
|
39
|
endif
|
40
|
40
|
|
|
41
|
+define Build/Prepare
|
|
42
|
+ $(PKG_UNPACK)
|
|
43
|
+ (cd $(PKG_BUILD_DIR) && tar -xf $(PKG_NAME)_$(PKG_VERSION)_src.tar && mv $(PKG_NAME)_$(PKG_VERSION)_src/* .)
|
|
44
|
+ $(Build/Patch)
|
|
45
|
+endef
|
|
46
|
+
|
41
|
47
|
define Build/Configure
|
42
|
48
|
cd $(PKG_BUILD_DIR); \
|
43
|
49
|
LINUX_CLIB="-DGLIBCV=2 $(LINUX_CLIB_IPV6)" \
|
44
|
50
|
LSOF_CC="$(TARGET_CC)" \
|
45
|
|
- LSOF_INCLUDE="-I$(STAGING_DIR)/usr/include" \
|
46
|
51
|
LSOF_VSTR="$(LINUX_VERSION)" \
|
47
|
52
|
LSOF_CFGF="$(TARGET_CFLAGS)" \
|
48
|
53
|
LSOF_CFGL="$(TARGET_LDFLAGS)" \
|