Browse Source

Merge pull request #159 from medaved/master

minidlna: Small patch for Philips TV open mkv
Ted Hess 10 years ago
parent
commit
e46e7034df

+ 4
- 0
multimedia/minidlna/Makefile View File

@@ -14,7 +14,11 @@ PKG_RELEASE:=1
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/minidlna
16 16
 PKG_MD5SUM:=879027192c89e5376cdd2ae2d1aa33b4
17
+
17 18
 PKG_MAINTAINER:=Knyazkov Dmitry <medavedik@gmail.com>
19
+
20
+PKG_LICENSE:=GPL-2.0
21
+PKG_LICENSE_FILE:=COPYING
18 22
 PKG_BUILD_PARALLEL:=0
19 23
 PKG_BUILD_DEPENDS:=util-linux
20 24
 

+ 12
- 0
multimedia/minidlna/patches/030-upnphttp-fixPhilips.patch View File

@@ -0,0 +1,12 @@
1
+--- a/upnphttp.c
2
++++ b/upnphttp.c
3
+@@ -1259,7 +1259,7 @@
4
+ 	int try_sendfile = 1;
5
+ #endif
6
+ 
7
+-	while( offset < end_offset )
8
++	while( offset <= end_offset )
9
+ 	{
10
+ #if HAVE_SENDFILE
11
+ 		if( try_sendfile )
12
+