Browse Source

libxerces-c: add new package

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 10 years ago
parent
commit
e5afac06fa
1 changed files with 95 additions and 0 deletions
  1. 95
    0
      libs/libxerces-c/Makefile

+ 95
- 0
libs/libxerces-c/Makefile View File

@@ -0,0 +1,95 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libxerces-c
11
+PKG_VERSION:=3.1.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_PROTO:=git
15
+PKG_SOURCE_URL:=git://git.apache.org/xerces-c.git
16
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
+PKG_SOURCE_VERSION:=Xerces-C_3_1_1
18
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
19
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
20
+
21
+PKG_LICENSE:=Apache-2.0
22
+PKG_LICENSE_FILES:=LICENSE
23
+
24
+PKG_BUILD_PARALLEL:=1
25
+PKG_FIXUP:=libtool
26
+PKG_INSTALL:=1
27
+
28
+include $(INCLUDE_DIR)/uclibc++.mk
29
+include $(INCLUDE_DIR)/package.mk
30
+
31
+CONFIGURE_ARGS += --disable-pretty-make
32
+TARGET_LDFLAGS += -lm
33
+
34
+define Package/libxerces-c
35
+  SECTION:=libs
36
+  CATEGORY:=Libraries
37
+  TITLE:=Validating XML parser library for C++
38
+  URL:=http://xerces.apache.org/
39
+  DEPENDS:=$(CXX_DEPENDS) +libc +libpthread
40
+endef
41
+
42
+define Package/libxerces-c-samples
43
+  SECTION:=libs
44
+  CATEGORY:=Libraries
45
+  TITLE:=Validating XML parser library for C++ (samples)
46
+  URL:=http://xerces.apache.org/
47
+  DEPENDS:=+libxerces-c
48
+endef
49
+
50
+define Build/Configure
51
+	(cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
52
+	./reconf;)
53
+	$(call Build/Configure/Default)
54
+endef
55
+
56
+define Package/libxerces-c/description
57
+  Xerces-C++ is a validating XML parser written in a portable subset of
58
+  C++. Xerces-C++ makes it easy to give your application the ability
59
+  to read and write XML data. A shared library is provided for parsing,
60
+  generating, manipulating, and validating XML documents. Xerces-C++ is
61
+  faithful to the XML 1.0 recommendation and associated standards (DOM
62
+  1.0, DOM 2.0, SAX 1.0, SAX 2.0, Namespaces, XML Schema Part 1 and
63
+  Part 2). It also provides experimental implementations of XML 1.1
64
+  and DOM Level 3.0. The parser provides high performance, modularity,
65
+  and scalability.
66
+endef
67
+
68
+define Package/libxerces-c-samples/description
69
+  Validating XML parser library for C++ (samples)
70
+endef
71
+
72
+define Build/InstallDev
73
+	$(INSTALL_DIR) $(1)/usr/include/xercesc/
74
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/xercesc/* $(1)/usr/include/xercesc/
75
+	$(INSTALL_DIR) $(1)/usr/lib
76
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxerces-c.a $(1)/usr/lib/
77
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxerces-c-3.1.so $(1)/usr/lib/
78
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxerces-c.so $(1)/usr/lib/
79
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
80
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xerces-c.pc $(1)/usr/lib/pkgconfig/xerces-c.pc
81
+endef
82
+
83
+define Package/libxerces-c/install
84
+	$(INSTALL_DIR) $(1)/usr/lib
85
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxerces-c-3.1.so $(1)/usr/lib/
86
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxerces-c.so $(1)/usr/lib/
87
+endef
88
+
89
+define Package/libxerces-c-samples/install
90
+	$(INSTALL_DIR) $(1)/usr/bin
91
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
92
+endef
93
+
94
+$(eval $(call BuildPackage,libxerces-c))
95
+$(eval $(call BuildPackage,libxerces-c-samples))