Browse Source

unzip: fix cross-compilation and skip target checks

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 10 years ago
parent
commit
e61b36871d
1 changed files with 4 additions and 1 deletions
  1. 4
    1
      utils/unzip/Makefile

+ 4
- 1
utils/unzip/Makefile View File

@@ -43,12 +43,15 @@ endef
43 43
 define Build/Configure
44 44
 endef
45 45
 
46
+TARGET_CFLAGS += -DNO_LCHMOD -DLARGE_FILE_SUPPORT
47
+
46 48
 define Build/Compile
47
-	$(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile generic \
49
+	$(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile unzips \
48 50
 		$(TARGET_CONFIGURE_OPTS) \
49 51
 		prefix="$(PKG_INSTALL_DIR)/usr" \
50 52
 		CFLAGS="$(TARGET_CFLAGS)" \
51 53
 		CF="$(TARGET_CFLAGS) -O $(TARGET_CPPFLAGS) -I. -DUNIX" \
54
+		CC="$(TARGET_CC)" \
52 55
 		LD="$(TARGET_CC) $(TARGET_LDFLAGS)" \
53 56
 		install
54 57
 endef