Browse Source

nspr: abandon package

Signed-off-by: Luka Perkov <luka@openwrt.org>
Luka Perkov 9 years ago
parent
commit
e632f4852d
2 changed files with 0 additions and 86 deletions
  1. 0
    60
      libs/nspr/Makefile
  2. 0
    26
      libs/nspr/patches/001-compile.patch

+ 0
- 60
libs/nspr/Makefile View File

@@ -1,60 +0,0 @@
1
-#
2
-# Copyright (C) 2014 OpenWrt.org
3
-#
4
-# This is free software, licensed under the GNU General Public License v2.
5
-# See /LICENSE for more information.
6
-#
7
-
8
-include $(TOPDIR)/rules.mk
9
-
10
-PKG_NAME:=nspr
11
-PKG_VERSION:=3.16.6
12
-PKG_RELEASE:=1
13
-
14
-PKG_BUILD_DIR:=$(BUILD_DIR)/nss-$(PKG_VERSION)
15
-PKG_SOURCE:=nss-$(PKG_VERSION)-with-nspr-4.10.6.tar.gz
16
-PKG_SOURCE_URL:=ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_3_16_6_RTM/src/
17
-PKG_MD5SUM:=4722706ea101948712b5ad003629679f
18
-PKG_INSTALL:=1
19
-
20
-include $(INCLUDE_DIR)/package.mk
21
-
22
-CONFIGURE_PATH=nspr
23
-MAKE_PATH=nspr
24
-
25
-define Package/nspr
26
-  SECTION:=libs
27
-  CATEGORY:=Libraries
28
-  TITLE:=Netscape Portable Runtime (NSPR)
29
-  URL:=https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR
30
-  DEPENDS:=+libpthread +librt
31
-  MAINTAINER:=Luka Perkov <luka@openwrt.org>
32
-endef
33
-
34
-define Package/nspr/description
35
-  Netscape Portable Runtime (NSPR) provides a platform-neutral API for system
36
-  level and libc-like functions. The API is used in the Mozilla clients, many of
37
-  Red Hat's and Sun's server applications, and other software offerings.
38
-endef
39
-
40
-CONFIGURE_ARGS += \
41
-	--with-arch=toolchain-default \
42
-	--with-fpu=toolchain-default \
43
-	--with-float-abi=toolchain-default \
44
-	--with-soft-float=toolchain-default
45
-
46
-define Build/InstallDev
47
-	$(INSTALL_DIR) $(1)/usr/
48
-	$(CP) $(PKG_INSTALL_DIR)/usr/include/ $(1)/usr/
49
-	$(INSTALL_DIR) $(1)/usr/lib
50
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*{a,so} $(1)/usr/lib/
51
-	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
52
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/nspr.pc $(1)/usr/lib/pkgconfig/
53
-endef
54
-
55
-define Package/nspr/install
56
-	$(INSTALL_DIR) $(1)/usr/lib
57
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*so $(1)/usr/lib
58
-endef
59
-
60
-$(eval $(call BuildPackage,nspr))

+ 0
- 26
libs/nspr/patches/001-compile.patch View File

@@ -1,26 +0,0 @@
1
---- a/nspr/config/Makefile.in
2
-+++ b/nspr/config/Makefile.in
3
-@@ -30,7 +30,6 @@ CSRCS	= now.c
4
- 
5
- # This version hasn't been ported for us; the one in mozilla/config has
6
- ifneq ($(OS_ARCH),OS2)
7
--CSRCS  += nsinstall.c
8
-  
9
- PLSRCS	= nfspwd.pl
10
- endif
11
-@@ -84,7 +83,6 @@ else
12
- ifeq (,$(filter-out SYMBIAN WINCE,$(OS_ARCH)))
13
- TARGETS = $(PROGS)
14
- else
15
--PROGS	+= $(OBJDIR)/nsinstall$(PROG_SUFFIX)
16
- TARGETS = $(PROGS) $(PLSRCS:.pl=)
17
- endif
18
- endif
19
-@@ -114,6 +112,7 @@ endif
20
- $(OBJDIR)/%$(PROG_SUFFIX): $(OBJDIR)/%.$(OBJ_SUFFIX)
21
- 	@$(MAKE_OBJDIR)
22
- 	$(CC) $(XCFLAGS) $< $(LDFLAGS) $(XLDOPTS) $(OUTOPTION)$@
23
-+	gcc nsinstall.c -o nsinstall
24
- 
25
- install:: nspr.m4
26
- 	$(NSINSTALL) -D $(DESTDIR)$(datadir)/aclocal