Browse Source

btrfs-progs: bump to 3.19.1

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 years ago
parent
commit
e6825ac677

+ 8
- 12
utils/btrfs-progs/Makefile View File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=btrfs-progs
11
-PKG_VERSION:=3.17.3
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=3.19.1
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
15 15
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs/
16
-PKG_MD5SUM:=6716b4b109dd909af63ab3becbad67a6
16
+PKG_MD5SUM:=ec3b3c99df18633ddc9e41f0680c5a51
17 17
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
18 18
 
19 19
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
@@ -24,6 +24,8 @@ PKG_INSTALL:=1
24 24
 PKG_BUILD_PARALLEL:=1
25 25
 PKG_BUILD_DEPENDS:=libacl
26 26
 
27
+PKG_FIXUP:=autoreconf
28
+
27 29
 include $(INCLUDE_DIR)/package.mk
28 30
 
29 31
 define Package/btrfs-progs
@@ -46,15 +48,9 @@ progs = btrfs btrfsck btrfs-convert btrfs-debug-tree btrfs-find-root \
46 48
 	btrfs-image btrfs-map-logical btrfs-show-super btrfstune \
47 49
 	btrfs-zero-log fsck.btrfs mkfs.btrfs
48 50
 
49
-
50
-MAKE_FLAGS+=\
51
-	CC="$(TARGET_CC)" \
52
-	CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
53
-	LDFLAGS="$(TARGET_LDFLAGS)" \
54
-	prefix=/usr \
55
-	DESTDIR=$(PKG_INSTALL_DIR) \
56
-	DISABLE_BACKTRACE=1 \
57
-	DISABLE_DOCUMENTATION=1
51
+CONFIGURE_ARGS += \
52
+	--disable-backtrace \
53
+	--disable-documentation
58 54
 
59 55
 define Package/btrfs-progs/install
60 56
 	$(INSTALL_DIR) $(1)/usr/lib

+ 48
- 24
utils/btrfs-progs/patches/001-fix-xattr-h-include-location.patch View File

@@ -1,16 +1,20 @@
1
---- a/mkfs.c
2
-+++ b/mkfs.c
3
-@@ -34,7 +34,7 @@
1
+Index: btrfs-progs-v3.19.1/mkfs.c
2
+===================================================================
3
+--- btrfs-progs-v3.19.1.orig/mkfs.c
4
++++ btrfs-progs-v3.19.1/mkfs.c
5
+@@ -31,7 +31,7 @@
4 6
  #include <getopt.h>
5 7
  #include <uuid/uuid.h>
6 8
  #include <ctype.h>
7 9
 -#include <sys/xattr.h>
8 10
 +#include <attr/xattr.h>
11
+ #include <limits.h>
12
+ #include <linux/limits.h>
9 13
  #include <blkid/blkid.h>
10
- #include <ftw.h>
11
- #include "ctree.h"
12
---- a/props.c
13
-+++ b/props.c
14
+Index: btrfs-progs-v3.19.1/props.c
15
+===================================================================
16
+--- btrfs-progs-v3.19.1.orig/props.c
17
++++ btrfs-progs-v3.19.1/props.c
14 18
 @@ -17,7 +17,7 @@
15 19
  #include <sys/stat.h>
16 20
  #include <sys/ioctl.h>
@@ -20,9 +24,11 @@
20 24
  #include <fcntl.h>
21 25
  #include <unistd.h>
22 26
  
23
---- a/cmds-receive.c
24
-+++ b/cmds-receive.c
25
-@@ -39,7 +39,7 @@
27
+Index: btrfs-progs-v3.19.1/cmds-receive.c
28
+===================================================================
29
+--- btrfs-progs-v3.19.1.orig/cmds-receive.c
30
++++ btrfs-progs-v3.19.1/cmds-receive.c
31
+@@ -34,7 +34,7 @@
26 32
  #include <sys/ioctl.h>
27 33
  #include <sys/time.h>
28 34
  #include <sys/types.h>
@@ -31,9 +37,11 @@
31 37
  #include <uuid/uuid.h>
32 38
  
33 39
  #include "ctree.h"
34
---- a/cmds-restore.c
35
-+++ b/cmds-restore.c
36
-@@ -34,7 +34,7 @@
40
+Index: btrfs-progs-v3.19.1/cmds-restore.c
41
+===================================================================
42
+--- btrfs-progs-v3.19.1.orig/cmds-restore.c
43
++++ btrfs-progs-v3.19.1/cmds-restore.c
44
+@@ -32,7 +32,7 @@
37 45
  #include <regex.h>
38 46
  #include <getopt.h>
39 47
  #include <sys/types.h>
@@ -42,14 +50,30 @@
42 50
  
43 51
  #include "ctree.h"
44 52
  #include "disk-io.h"
45
---- a/Makefile
46
-+++ b/Makefile
47
-@@ -26,7 +26,7 @@ TESTS = fsck-tests.sh convert-tests.sh
48
- INSTALL = install
49
- prefix ?= /usr/local
50
- bindir = $(prefix)/bin
51
--lib_LIBS = -luuid -lblkid -lm -lz -llzo2 -L.
52
-+lib_LIBS = -lattr -luuid -lblkid -lm -lz -llzo2 -L.
53
- libdir ?= $(prefix)/lib
54
- incdir = $(prefix)/include/btrfs
55
- LIBS = $(lib_LIBS) $(libs_static)
53
+Index: btrfs-progs-v3.19.1/Makefile.in
54
+===================================================================
55
+--- btrfs-progs-v3.19.1.orig/Makefile.in
56
++++ btrfs-progs-v3.19.1/Makefile.in
57
+@@ -21,7 +21,7 @@ CFLAGS = @CFLAGS@ \
58
+ LDFLAGS = @LDFLAGS@ \
59
+ 	  -rdynamic
60
+ 
61
+-LIBS = @UUID_LIBS@ @BLKID_LIBS@ @ZLIB_LIBS@ @LZO2_LIBS@ -L. -pthread
62
++LIBS = @ATTR_LIBS@ @UUID_LIBS@ @BLKID_LIBS@ @ZLIB_LIBS@ @LZO2_LIBS@ -L. -pthread
63
+ LIBBTRFS_LIBS = $(LIBS)
64
+ 
65
+ # Static compilation flags
66
+Index: btrfs-progs-v3.19.1/configure.ac
67
+===================================================================
68
+--- btrfs-progs-v3.19.1.orig/configure.ac
69
++++ btrfs-progs-v3.19.1/configure.ac
70
+@@ -115,6 +115,9 @@ dnl
71
+ dnl The default PKG_CHECK_MODULES() action-if-not-found is end the
72
+ dnl execution with error. The static libs are optional.
73
+ 
74
++PKG_CHECK_MODULES(ATTR, [libattr])
75
++PKG_STATIC(BLKID_LIBS_STATIC, [libattr])
76
++
77
+ PKG_CHECK_MODULES(BLKID, [blkid])
78
+ PKG_STATIC(BLKID_LIBS_STATIC, [blkid])
79
+