Browse Source

gnunet: work-around libmicrohttpd detection

Bug filed upstream:
https://gnunet.org/bugs/view.php?id=3805

Once fixed, this patch can be removed.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 years ago
parent
commit
e6deb6136a
1 changed files with 68 additions and 0 deletions
  1. 68
    0
      net/gnunet/patches/013-work-around-libmicrohttpd-detection.patch

+ 68
- 0
net/gnunet/patches/013-work-around-libmicrohttpd-detection.patch View File

@@ -0,0 +1,68 @@
1
+Index: gnunet-0.10.1-svn35844/configure.ac
2
+===================================================================
3
+--- gnunet-0.10.1-svn35844.orig/configure.ac
4
++++ gnunet-0.10.1-svn35844/configure.ac
5
+@@ -854,14 +854,7 @@ AC_ARG_WITH(microhttpd,
6
+         AC_CHECK_HEADERS([microhttpd.h],
7
+ 	  AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
8
+             AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
9
+-              [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
10
+-              AC_RUN_IFELSE([AC_LANG_SOURCE([
11
+-                #include "$native_srcdir/src/include/platform.h"
12
+-                #include <microhttpd.h>
13
+-                int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
14
+-               ])], [
15
+-               AC_MSG_RESULT(ok)
16
+-               lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
17
++              ),
18
+ 	    [],[#include "$native_srcdir/src/include/platform.h"
19
+                 #include <microhttpd.h>]),,
20
+             [#include "$native_srcdir/src/include/platform.h"])
21
+@@ -873,14 +866,7 @@ AC_ARG_WITH(microhttpd,
22
+ 	  AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
23
+             AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
24
+               EXT_LIB_PATH="-L$with_microhttpd/lib $EXT_LIB_PATH"
25
+-              [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
26
+-               AC_RUN_IFELSE([AC_LANG_SOURCE([
27
+-                #include "$native_srcdir/src/include/platform.h"
28
+-                #include <microhttpd.h>
29
+-                int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
30
+-               ])], [
31
+-               AC_MSG_RESULT(ok)
32
+-               lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
33
++              ),
34
+ 	    [],[#include "$native_srcdir/src/include/platform.h"
35
+                 #include <microhttpd.h>]),,
36
+             [#include "$native_srcdir/src/include/platform.h"])
37
+@@ -891,19 +877,12 @@ AC_ARG_WITH(microhttpd,
38
+     AC_CHECK_HEADERS([microhttpd.h],
39
+       AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
40
+         AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
41
+-          [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
42
+-              AC_RUN_IFELSE([AC_LANG_SOURCE([
43
+-                #include "$native_srcdir/src/include/platform.h"
44
+-		#include <microhttpd.h>
45
+-                int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
46
+-               ])], [
47
+-               AC_MSG_RESULT(ok)
48
+-               lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
49
++	),
50
+ 	[],[#include "$native_srcdir/src/include/platform.h"
51
+             #include <microhttpd.h>]),,
52
+        [#include "$native_srcdir/src/include/platform.h"])])
53
+-AM_CONDITIONAL(HAVE_MHD, test x$lmhd = x1)
54
+-AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd])
55
++AM_CONDITIONAL(HAVE_MHD, test x1 = x1)
56
++AC_DEFINE_UNQUOTED([HAVE_MHD], 1, [We have libmicrohttpd])
57
+ 
58
+ 
59
+ # restore LIBS
60
+@@ -1655,7 +1634,7 @@ then
61
+ fi
62
+ 
63
+ # MHD
64
+-if test "x$lmhd" != "x1"
65
++if test "x1" != "x1"
66
+ then
67
+  AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.])
68
+ fi