|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2006-2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2006-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -8,12 +8,12 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=ffmpeg
|
11
|
|
-PKG_VERSION:=2.4.5
|
|
11
|
+PKG_VERSION:=2.5.3
|
12
|
12
|
PKG_RELEASE:=1
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
15
|
15
|
PKG_SOURCE_URL:=http://ffmpeg.org/releases/
|
16
|
|
-PKG_MD5SUM:=685362fc14d2c28568a5d36b3760795a
|
|
16
|
+PKG_MD5SUM:=efba7c5cfbea9ce58ff693cd08f90ffa
|
17
|
17
|
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
18
|
18
|
|
19
|
19
|
PKG_LICENSE:=LGPL-2.1+ GPL-2+ LGPL-3
|
|
@@ -389,6 +389,7 @@ FFMPEG_CONFIGURE:= \
|
389
|
389
|
--disable-neon \
|
390
|
390
|
--disable-inline-asm \
|
391
|
391
|
--disable-yasm \
|
|
392
|
+ --disable-mips32r2 \
|
392
|
393
|
--disable-mipsdspr1 \
|
393
|
394
|
--disable-mipsdspr2 \
|
394
|
395
|
--disable-mipsfpu \
|
|
@@ -399,10 +400,6 @@ FFMPEG_CONFIGURE:= \
|
399
|
400
|
--disable-vdpau \
|
400
|
401
|
--disable-outdevs
|
401
|
402
|
|
402
|
|
-ifeq ($(CONFIG_CPU_TYPE),"mips32")
|
403
|
|
- FFMPEG_CONFIGURE +=--disable-mips32r2
|
404
|
|
-endif
|
405
|
|
-
|
406
|
403
|
ifeq ($(BUILD_VARIANT),custom)
|
407
|
404
|
|
408
|
405
|
FFMPEG_ENABLE= \
|