Browse Source

mosquitto: upgrade to version 1.4.4

Drop patch now included upstream.

More information: http://mosquitto.org/2015/09/version-1-4-4-released/

Signed-off-by: Karl Palsson <karlp@tweak.net.au>
Karl Palsson 9 years ago
parent
commit
e7bd3fbe21
2 changed files with 3 additions and 17 deletions
  1. 3
    3
      net/mosquitto/Makefile
  2. 0
    14
      net/mosquitto/patches/001-free-counting-bug-475707.patch

+ 3
- 3
net/mosquitto/Makefile View File

@@ -9,14 +9,14 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=mosquitto
12
-PKG_VERSION:=1.4.3
13
-PKG_RELEASE:=2
12
+PKG_VERSION:=1.4.4
13
+PKG_RELEASE:=1
14 14
 PKG_LICENSE:=BSD-3-Clause
15 15
 PKG_LICENSE_FILES:=LICENSE.txt
16 16
 
17 17
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
18 18
 PKG_SOURCE_URL:=http://mosquitto.org/files/source/
19
-PKG_MD5SUM:=1c1c750525546bc13d8d72e56a0742a7
19
+PKG_MD5SUM:=89a57f11cdfec140fa21fe3d4493b2ca
20 20
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
21 21
 
22 22
 include $(INCLUDE_DIR)/package.mk

+ 0
- 14
net/mosquitto/patches/001-free-counting-bug-475707.patch View File

@@ -1,14 +0,0 @@
1
-diff --git a/lib/memory_mosq.c b/lib/memory_mosq.c
2
-index b1f5bfd..4d8217d 100644
3
---- a/lib/memory_mosq.c
4
-+++ b/lib/memory_mosq.c
5
-@@ -54,6 +54,9 @@ void *mosquitto__calloc(size_t nmemb, size_t size)
6
- void mosquitto__free(void *mem)
7
- {
8
- #ifdef REAL_WITH_MEMORY_TRACKING
9
-+	if(!mem){
10
-+		return;
11
-+	}
12
- 	memcount -= malloc_usable_size(mem);
13
- #endif
14
- 	free(mem);