Просмотр исходного кода

import giflib from oldpackages, update to 5.1.0 and add myself as maintainer

Signed-off-by: Oliver Ertl <oliver-ertl@t-online.de>
Oliver Ertl 10 лет назад
Родитель
Сommit
e7d2488e51
1 измененных файлов: 60 добавлений и 0 удалений
  1. 60
    0
      libs/giflib/Makefile

+ 60
- 0
libs/giflib/Makefile Просмотреть файл

@@ -0,0 +1,60 @@
1
+#
2
+# Copyright (C) 2006-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=giflib
11
+PKG_VERSION:=5.1.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=@SF/giflib
16
+PKG_MD5SUM:=c7e9f1c10b755ab955156d4c1ac7fc5d
17
+
18
+PKG_LICENSE:=MIT
19
+PKG_LICENSE_FILES:=COPYING
20
+
21
+PKG_FIXUP:=autoreconf
22
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/giflib
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  TITLE:=GIF libraries
30
+  URL:=http://sourceforge.net/projects/giflib
31
+  MAINTAINER:=Oliver Ertl <oliver-ertl@t-online.de>
32
+endef
33
+
34
+define Package/giflib/description
35
+  giflib is a library for reading and writing gif images.
36
+  It is API and ABI compatible with libungif which was in wide use while
37
+  the LZW compression algorithm was patented.
38
+endef
39
+
40
+TARGET_CFLAGS += $(FPIC)
41
+CONFIGURE_ARGS += --enable-x11=no
42
+
43
+define Build/Compile
44
+	$(MAKE) -C $(PKG_BUILD_DIR)
45
+endef
46
+
47
+define Build/InstallDev
48
+	$(INSTALL_DIR) $(1)/usr/{lib,include}
49
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib
50
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/libgif.a $(1)/usr/lib
51
+	$(CP) $(PKG_BUILD_DIR)/lib/libgif.la $(1)/usr/lib
52
+	$(CP) $(PKG_BUILD_DIR)/lib/*.h $(1)/usr/include/
53
+endef
54
+
55
+define Package/giflib/install
56
+	$(INSTALL_DIR) $(1)/usr/lib
57
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib/
58
+endef
59
+
60
+$(eval $(call BuildPackage,giflib))