Переглянути джерело

wifidog: Bump to 1.3.0

* Updates wifidog to latest upstream release.
* Removes patches/100-musl-compat.patch as that's included in 1.3.0

Signed-off-by: Michael Haas <haas@computerlinguist.org>
Michael Haas 9 роки тому
джерело
коміт
e86e8d9d35
2 змінених файлів з 3 додано та 50 видалено
  1. 3
    3
      net/wifidog/Makefile
  2. 0
    47
      net/wifidog/patches/100-musl-compat.patch

+ 3
- 3
net/wifidog/Makefile Переглянути файл

@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=wifidog
11
-PKG_VERSION:=1.2.1
12
-PKG_RELEASE=2
11
+PKG_VERSION:=1.3.0
12
+PKG_RELEASE=1
13 13
 
14 14
 
15 15
 PKG_LICENSE:=GPL-2.0
@@ -22,7 +22,7 @@ PKG_LICENSE_FILES:=COPYING
22 22
 PKG_SOURCE_PROTO:=git
23 23
 PKG_SOURCE_URL:=git://github.com/wifidog/wifidog-gateway.git
24 24
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
25
-PKG_SOURCE_VERSION:=1.2.1
25
+PKG_SOURCE_VERSION:=1.3.0
26 26
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
27 27
 
28 28
 PKG_FIXUP:=autoreconf

+ 0
- 47
net/wifidog/patches/100-musl-compat.patch Переглянути файл

@@ -1,47 +0,0 @@
1
---- a/libhttpd/protocol.c
2
-+++ b/libhttpd/protocol.c
3
-@@ -28,6 +28,7 @@
4
- 
5
- #if defined(_WIN32)
6
- #else
7
-+#include <fcntl.h>
8
- #include <unistd.h>
9
- #include <sys/file.h>
10
- #endif
11
---- a/src/firewall.c
12
-+++ b/src/firewall.c
13
-@@ -35,7 +35,6 @@
14
- #include <pthread.h>
15
- #include <sys/wait.h>
16
- #include <sys/types.h>
17
--#include <sys/unistd.h>
18
- 
19
- #include <string.h>
20
- 
21
---- a/src/client_list.c
22
-+++ b/src/client_list.c
23
-@@ -31,9 +31,9 @@
24
- #include <syslog.h>
25
- #include <errno.h>
26
- #include <pthread.h>
27
-+#include <unistd.h>
28
- #include <sys/wait.h>
29
- #include <sys/types.h>
30
--#include <sys/unistd.h>
31
- 
32
- #include <string.h>
33
- 
34
---- a/src/util.c
35
-+++ b/src/util.c
36
-@@ -33,10 +33,10 @@
37
- #include <syslog.h>
38
- #include <errno.h>
39
- #include <pthread.h>
40
-+#include <unistd.h>
41
- #include <sys/wait.h>
42
- #include <sys/types.h>
43
- #include <sys/time.h>
44
--#include <sys/unistd.h>
45
- #include <netinet/in.h>
46
- #include <sys/ioctl.h>
47
- #include <arpa/inet.h>