Browse Source

gst1-plugins-bad: Update to 1.4.5, fix build deps, refresh patches

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
e8a8f20d31

+ 6
- 4
multimedia/gst1-plugins-bad/Makefile View File

@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gst1-plugins-bad
11
-PKG_VERSION:=1.4.4
12
-PKG_RELEASE:=5
11
+PKG_VERSION:=1.4.5
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -19,9 +19,9 @@ PKG_LICENSE_FILES:=COPYING.LIB COPYING
19 19
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-bad-$(PKG_VERSION)
20 20
 PKG_SOURCE:=gst-plugins-bad-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
22
-PKG_MD5SUM:=972c6e22dd2e44fcf0b04b9d810a56be
22
+PKG_MD5SUM:=e0bb39412cf4a48fe0397bcf3a7cd451
23 23
 
24
-PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
24
+PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base
25 25
 
26 26
 PKG_FIXUP:=autoreconf
27 27
 PKG_INSTALL:=1
@@ -148,9 +148,11 @@ CONFIGURE_ARGS += \
148 148
 	--disable-schro \
149 149
 	--disable-zbar \
150 150
 	--disable-srtp \
151
+	--disable-hls \
151 152
 	\
152 153
 	--without-libiconv-prefix \
153 154
 	--without-libintl-prefix \
155
+	--with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
154 156
 	--without-x \
155 157
 
156 158
 TARGET_CFLAGS+= -std=gnu99

+ 10
- 13
multimedia/gst1-plugins-bad/patches/000-gettext.patch View File

@@ -1,18 +1,16 @@
1
-diff -u --recursive gst-plugins-bad-1.0.7-vanilla/configure.ac gst-plugins-bad-1.0.7/configure.ac
2
---- gst-plugins-bad-1.0.7-vanilla/configure.ac	2013-06-01 19:44:32.199308073 -0500
3
-+++ gst-plugins-bad-1.0.7/configure.ac	2013-06-01 19:45:27.754119344 -0500
4
-@@ -2373,7 +2373,6 @@
5
- ext/timidity/Makefile
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -3334,7 +3334,6 @@ ext/timidity/Makefile
4
+ ext/webp/Makefile
6 5
  ext/xvid/Makefile
7 6
  ext/zbar/Makefile
8 7
 -po/Makefile.in
9 8
  docs/Makefile
10 9
  docs/plugins/Makefile
11 10
  docs/libs/Makefile
12
-diff -u --recursive gst-plugins-bad-1.0.7-vanilla/Makefile.am gst-plugins-bad-1.0.7/Makefile.am
13
---- gst-plugins-bad-1.0.7-vanilla/Makefile.am	2013-06-01 19:44:32.165309412 -0500
14
-+++ gst-plugins-bad-1.0.7/Makefile.am	2013-06-01 19:45:39.016675625 -0500
15
-@@ -2,11 +2,11 @@
11
+--- a/Makefile.am
12
++++ b/Makefile.am
13
+@@ -2,11 +2,11 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-d
16 14
  
17 15
  SUBDIRS = \
18 16
  	gst-libs gst sys ext pkgconfig \
@@ -26,10 +24,9 @@ diff -u --recursive gst-plugins-bad-1.0.7-vanilla/Makefile.am gst-plugins-bad-1.
26 24
  
27 25
  # include before EXTRA_DIST for win32 assignment
28 26
  include $(top_srcdir)/common/win32.mak
29
-diff -u --recursive gst-plugins-bad-1.0.7-vanilla/Makefile.in gst-plugins-bad-1.0.7/Makefile.in
30
---- gst-plugins-bad-1.0.7-vanilla/Makefile.in	2013-06-01 19:44:32.217307364 -0500
31
-+++ gst-plugins-bad-1.0.7/Makefile.in	2013-06-01 19:45:44.624454691 -0500
32
-@@ -636,11 +636,11 @@
27
+--- a/Makefile.in
28
++++ b/Makefile.in
29
+@@ -739,11 +739,11 @@ wayland_scanner = @wayland_scanner@
33 30
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
34 31
  SUBDIRS = \
35 32
  	gst-libs gst sys ext pkgconfig \