|
@@ -1,6 +1,6 @@
|
1
|
1
|
--- a/Makefile
|
2
|
2
|
+++ b/Makefile
|
3
|
|
-@@ -529,16 +529,7 @@ EXTRA_PROGRAMS =
|
|
3
|
+@@ -538,16 +538,7 @@ EXTRA_PROGRAMS =
|
4
|
4
|
# ... and all the rest that could be moved out of bindir to gitexecdir
|
5
|
5
|
PROGRAMS += $(EXTRA_PROGRAMS)
|
6
|
6
|
|
|
@@ -18,7 +18,7 @@
|
18
|
18
|
|
19
|
19
|
# Binary suffix, set to .exe for Windows builds
|
20
|
20
|
X =
|
21
|
|
-@@ -887,6 +878,12 @@ BUILTIN_OBJS += builtin/verify-commit.o
|
|
21
|
+@@ -896,6 +887,12 @@ BUILTIN_OBJS += builtin/verify-commit.o
|
22
|
22
|
BUILTIN_OBJS += builtin/verify-pack.o
|
23
|
23
|
BUILTIN_OBJS += builtin/verify-tag.o
|
24
|
24
|
BUILTIN_OBJS += builtin/write-tree.o
|
|
@@ -31,7 +31,7 @@
|
31
|
31
|
|
32
|
32
|
GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
|
33
|
33
|
EXTLIBS =
|
34
|
|
-@@ -1049,7 +1046,7 @@ endif
|
|
34
|
+@@ -1070,7 +1067,7 @@ endif
|
35
|
35
|
EXTLIBS += -lz
|
36
|
36
|
|
37
|
37
|
ifndef NO_OPENSSL
|
|
@@ -40,18 +40,18 @@
|
40
|
40
|
ifdef OPENSSLDIR
|
41
|
41
|
BASIC_CFLAGS += -I$(OPENSSLDIR)/include
|
42
|
42
|
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
|
43
|
|
-@@ -1901,10 +1898,6 @@ endif
|
|
43
|
+@@ -1933,10 +1930,6 @@ endif
|
44
|
44
|
git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
|
45
|
45
|
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
|
46
|
46
|
|
47
|
|
--git-imap-send$X: imap-send.o GIT-LDFLAGS $(GITLIBS)
|
|
47
|
+-git-imap-send$X: imap-send.o $(IMAP_SEND_BUILDDEPS) GIT-LDFLAGS $(GITLIBS)
|
48
|
48
|
- $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
|
49
|
|
-- $(LIBS) $(OPENSSL_LINK) $(OPENSSL_LIBSSL) $(LIB_4_CRYPTO)
|
|
49
|
+- $(LIBS) $(IMAP_SEND_LDFLAGS)
|
50
|
50
|
-
|
51
|
51
|
git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
|
52
|
52
|
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
|
53
|
53
|
$(LIBS) $(CURL_LIBCURL)
|
54
|
|
-@@ -2222,24 +2215,22 @@ endif
|
|
54
|
+@@ -2254,24 +2247,22 @@ endif
|
55
|
55
|
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
|
56
|
56
|
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
|
57
|
57
|
{ test "$$bindir/" = "$$execdir/" || \
|
|
@@ -159,7 +159,7 @@
|
159
|
159
|
|
160
|
160
|
--- a/git.c
|
161
|
161
|
+++ b/git.c
|
162
|
|
-@@ -312,11 +312,11 @@ static int handle_alias(int *argcp, cons
|
|
162
|
+@@ -309,11 +309,11 @@ static int handle_alias(int *argcp, cons
|
163
|
163
|
|
164
|
164
|
struct cmd_struct {
|
165
|
165
|
const char *cmd;
|
|
@@ -173,7 +173,7 @@
|
173
|
173
|
{
|
174
|
174
|
int status, help;
|
175
|
175
|
struct stat st;
|
176
|
|
-@@ -396,6 +396,7 @@ static struct cmd_struct commands[] = {
|
|
176
|
+@@ -393,6 +393,7 @@ static struct cmd_struct commands[] = {
|
177
|
177
|
{ "config", cmd_config, RUN_SETUP_GENTLY },
|
178
|
178
|
{ "count-objects", cmd_count_objects, RUN_SETUP },
|
179
|
179
|
{ "credential", cmd_credential, RUN_SETUP_GENTLY },
|
|
@@ -181,7 +181,7 @@
|
181
|
181
|
{ "describe", cmd_describe, RUN_SETUP },
|
182
|
182
|
{ "diff", cmd_diff },
|
183
|
183
|
{ "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE },
|
184
|
|
-@@ -414,6 +415,8 @@ static struct cmd_struct commands[] = {
|
|
184
|
+@@ -411,6 +412,8 @@ static struct cmd_struct commands[] = {
|
185
|
185
|
{ "grep", cmd_grep, RUN_SETUP_GENTLY },
|
186
|
186
|
{ "hash-object", cmd_hash_object },
|
187
|
187
|
{ "help", cmd_help },
|
|
@@ -190,7 +190,7 @@
|
190
|
190
|
{ "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
|
191
|
191
|
{ "init", cmd_init_db, NO_SETUP },
|
192
|
192
|
{ "init-db", cmd_init_db, NO_SETUP },
|
193
|
|
-@@ -462,6 +465,7 @@ static struct cmd_struct commands[] = {
|
|
193
|
+@@ -459,6 +462,7 @@ static struct cmd_struct commands[] = {
|
194
|
194
|
{ "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
|
195
|
195
|
{ "rm", cmd_rm, RUN_SETUP },
|
196
|
196
|
{ "send-pack", cmd_send_pack, RUN_SETUP },
|
|
@@ -198,7 +198,7 @@
|
198
|
198
|
{ "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
|
199
|
199
|
{ "show", cmd_show, RUN_SETUP },
|
200
|
200
|
{ "show-branch", cmd_show_branch, RUN_SETUP },
|
201
|
|
-@@ -478,6 +482,7 @@ static struct cmd_struct commands[] = {
|
|
201
|
+@@ -475,6 +479,7 @@ static struct cmd_struct commands[] = {
|
202
|
202
|
{ "update-server-info", cmd_update_server_info, RUN_SETUP },
|
203
|
203
|
{ "upload-archive", cmd_upload_archive },
|
204
|
204
|
{ "upload-archive--writer", cmd_upload_archive_writer },
|
|
@@ -219,15 +219,15 @@
|
219
|
219
|
char *dir;
|
220
|
220
|
--- a/imap-send.c
|
221
|
221
|
+++ b/imap-send.c
|
222
|
|
-@@ -1338,7 +1338,7 @@ static void git_imap_config(void)
|
223
|
|
- git_config_get_string("imap.authmethod", &server.auth_method);
|
|
222
|
+@@ -1484,7 +1484,7 @@ static int curl_append_msgs_to_imap(stru
|
224
|
223
|
}
|
|
224
|
+ #endif
|
225
|
225
|
|
226
|
226
|
-int main(int argc, char **argv)
|
227
|
227
|
+int cmd_imap_send(int argc, char **argv, const char *prefix)
|
228
|
228
|
{
|
229
|
229
|
struct strbuf all_msgs = STRBUF_INIT;
|
230
|
|
- struct strbuf msg = STRBUF_INIT;
|
|
230
|
+ int total;
|
231
|
231
|
--- a/shell.c
|
232
|
232
|
+++ b/shell.c
|
233
|
233
|
@@ -138,7 +138,7 @@ static struct commands {
|
|
@@ -241,7 +241,7 @@
|
241
|
241
|
const char **user_argv;
|
242
|
242
|
--- a/upload-pack.c
|
243
|
243
|
+++ b/upload-pack.c
|
244
|
|
-@@ -791,7 +791,7 @@ static int upload_pack_config(const char
|
|
244
|
+@@ -793,7 +793,7 @@ static int upload_pack_config(const char
|
245
|
245
|
return parse_hide_refs_config(var, value, "uploadpack");
|
246
|
246
|
}
|
247
|
247
|
|