浏览代码

snort: fix build with CONFIG_PKG_CHECK_FORMAT_SECURITY

The configure script incorrectly mangles `CFLAGS` by attempting to remove
`-Werror` from it, thus turning `-Werror=format-security` into just
`=format-security` which will cause subsequent autoconf tests to fail.

Patch out the custom `CFLAGS` mangling to fix the build.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 年前
父节点
当前提交
eaf4652760
共有 2 个文件被更改,包括 18 次插入1 次删除
  1. 1
    1
      net/snort/Makefile
  2. 17
    0
      net/snort/patches/100-autoconf-fixes.patch

+ 1
- 1
net/snort/Makefile 查看文件

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=snort
11 11
 PKG_VERSION:=2.9.7.2
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://www.snort.org/downloads/snort/ \

+ 17
- 0
net/snort/patches/100-autoconf-fixes.patch 查看文件

@@ -0,0 +1,17 @@
1
+--- a/configure.in
2
++++ b/configure.in
3
+@@ -11,14 +11,6 @@ AM_INIT_AUTOMAKE(snort,2.9.7.2)
4
+ NO_OPTIMIZE="no"
5
+ ADD_WERROR="no"
6
+ 
7
+-# Test for -Werror and sed it out for now since some of the auto tests,
8
+-# for example AC_CHECK_LIB, will fail because of
9
+-# warning: conflicting types for built-in function <func>
10
+-if eval "echo $CFLAGS | grep -e -Werror"; then
11
+-    CFLAGS=`echo $CFLAGS | sed -e "s/-Werror//g"`
12
+-    ADD_WERROR="yes"
13
+-fi
14
+-
15
+ # Disable annoying practice of recursively re-running the autotools
16
+ AM_MAINTAINER_MODE
17
+ AC_PROG_CC_STDC