Browse Source

gnutls: corrected compilation of tools when OCSP is disabled

Resolves #640
Nikos Mavrogiannopoulos 10 years ago
parent
commit
ec2d4aeebd
2 changed files with 52 additions and 1 deletions
  1. 1
    1
      libs/gnutls/Makefile
  2. 51
    0
      libs/gnutls/patches/002-ocsp-in-tools.patch

+ 1
- 1
libs/gnutls/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnutls
11 11
 PKG_VERSION:=3.3.11
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 PKG_USE_MIPS16:=0
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz

+ 51
- 0
libs/gnutls/patches/002-ocsp-in-tools.patch View File

@@ -0,0 +1,51 @@
1
+diff --git a/src/cli-debug.c b/src/cli-debug.c
2
+index 5f9eb00..a8dde6c 100644
3
+--- a/src/cli-debug.c
4
++++ b/src/cli-debug.c
5
+@@ -165,8 +165,10 @@ static const TLS_TEST tls_tests[] = {
6
+ #endif
7
+ 	{"for max record size (RFC6066) support", test_max_record_size, "yes",
8
+ 	 "no", "dunno"},
9
++#ifdef ENABLE_OCSP
10
+ 	{"for OCSP status response (RFC6066) support", test_ocsp_status, "yes",
11
+ 	 "no", "dunno"},
12
++#endif
13
+ 	{"for OpenPGP authentication (RFC6091) support", test_openpgp1,
14
+ 	 "yes", "no", "dunno"},
15
+ 	{NULL, NULL, NULL, NULL, NULL}
16
+diff --git a/src/common.c b/src/common.c
17
+index fff9449..ffa1896 100644
18
+--- a/src/common.c
19
++++ b/src/common.c
20
+@@ -572,9 +572,11 @@ int print_info(gnutls_session_t session, int verbose, int print_cert)
21
+ 	printf("- Options:");
22
+ 	if (gnutls_safe_renegotiation_status(session)!=0)
23
+ 		printf(" safe renegotiation,");
24
++#ifdef ENABLE_OCSP
25
+ 	if (gnutls_ocsp_status_request_get(session, &resp)==0) {
26
+ 		printf(" OCSP status request%s,", gnutls_ocsp_status_request_is_checked(session,0)!=0?"":"[ignored]");
27
+ 	}
28
++#endif
29
+ 	printf("\n");
30
+ 
31
+ #ifdef ENABLE_DTLS_SRTP
32
+diff --git a/src/tests.c b/src/tests.c
33
+index 6cb251d..5c45159 100644
34
+--- a/src/tests.c
35
++++ b/src/tests.c
36
+@@ -246,6 +246,7 @@ test_code_t test_safe_renegotiation(gnutls_session_t session)
37
+ 	return ret;
38
+ }
39
+ 
40
++#ifdef ENABLE_OCSP
41
+ test_code_t test_ocsp_status(gnutls_session_t session)
42
+ {
43
+ 	int ret;
44
+@@ -275,6 +276,7 @@ test_code_t test_ocsp_status(gnutls_session_t session)
45
+ 
46
+ 	return TEST_FAILED;
47
+ }
48
++#endif
49
+ 
50
+ test_code_t test_safe_renegotiation_scsv(gnutls_session_t session)
51
+ {