Browse Source

Merge pull request #750 from bk138/gcc-include-libgcc-a

GCC: include libgcc.a
Steven Barth 10 years ago
parent
commit
ed6e69f860
2 changed files with 6 additions and 3 deletions
  1. 1
    0
      devel/gcc/Makefile
  2. 5
    3
      devel/gcc/README

+ 1
- 0
devel/gcc/Makefile View File

@@ -110,6 +110,7 @@ define Package/gcc/install
110 110
 	cp -ar $(TOOLCHAIN_DIR)/include $(1)/usr/lib/$(PKG_NAME)/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION)
111 111
 	cp -a $(TOOLCHAIN_DIR)/lib/*.{o,so*} $(1)/usr/lib/$(PKG_NAME)/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION)
112 112
 	cp -a $(TOOLCHAIN_DIR)/lib/*nonshared*.a  $(1)/usr/lib/$(PKG_NAME)/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION)
113
+	grep "GROUP.*-lgcc" $(1)/usr/lib/$(PKG_NAME)/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION)/libgcc_s.so && cp -a $(PKG_INSTALL_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION)/libgcc.a $(1)/usr/lib/$(PKG_NAME)/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION)/ ; true
113 114
 endef
114 115
 
115 116
 $(eval $(call BuildPackage,gcc))

+ 5
- 3
devel/gcc/README View File

@@ -1,8 +1,10 @@
1 1
 Native GCC that runs on target.
2 2
 
3 3
 To save disk space, this GCC only supports dynamic linking on the target box,
4
-there are no static libraries shipped.
4
+there are no static libraries shipped except libgcc.a on those architectures
5
+that need it.
5 6
 
6
-For now, this was only tested on a mips target. Others to be done...
7
+For now, this was only tested on arm (EABI) and mips targets. Others to be
8
+done...
7 9
 
8
-   Christian Beier <cb@shoutrlabs.com>
10
+   Christian Beier <cb@shoutrlabs.com>