|
@@ -0,0 +1,46 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2016 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=service_identity
|
|
11
|
+PKG_VERSION:=16.0.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/service_identity
|
|
16
|
+PKG_MD5SUM:=d52392597b9c44a740abf322bfdb21e6
|
|
17
|
+
|
|
18
|
+PKG_BUILD_DEPENDS:=python python-setuptools
|
|
19
|
+
|
|
20
|
+PKG_LICENSE:=MIT
|
|
21
|
+PKG_LICENSE_FILES:=LICENSE
|
|
22
|
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+$(call include_mk, python-package.mk)
|
|
26
|
+
|
|
27
|
+define Package/python-service-identity
|
|
28
|
+ SECTION:=lang
|
|
29
|
+ CATEGORY:=Languages
|
|
30
|
+ SUBMENU:=Python
|
|
31
|
+ TITLE:=python-service-identity
|
|
32
|
+ URL:=https://github.com/pyca/service_identity
|
|
33
|
+ DEPENDS:=+python-light +python-attrs +python-pyasn1 +python-pyasn1-modules +python-pyopenssl
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/python-service-identity/description
|
|
37
|
+service_identity aspires to give you all the tools you need for
|
|
38
|
+verifying whether a certificate is valid for the intended purposes.
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+define Build/Compile
|
|
42
|
+ $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+$(eval $(call PyPackage,python-service-identity))
|
|
46
|
+$(eval $(call BuildPackage,python-service-identity))
|