|
@@ -0,0 +1,100 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libxml2
|
|
11
|
+PKG_VERSION:=2.9.1
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://gd.tuwien.ac.at/languages/libxml/ \
|
|
16
|
+ http://xmlsoft.org/sources/ \
|
|
17
|
+ ftp://fr.rpmfind.net/pub/libxml/
|
|
18
|
+PKG_MD5SUM:=9c0cfef285d5c4a5c80d00904ddab380
|
|
19
|
+
|
|
20
|
+PKG_LICENSE:=MIT
|
|
21
|
+PKG_LICENSE_FILES:=COPYING
|
|
22
|
+
|
|
23
|
+PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
|
24
|
+
|
|
25
|
+PKG_FIXUP:=autoreconf
|
|
26
|
+PKG_INSTALL:=1
|
|
27
|
+PKG_BUILD_PARALLEL:=1
|
|
28
|
+
|
|
29
|
+include $(INCLUDE_DIR)/package.mk
|
|
30
|
+
|
|
31
|
+define Package/libxml2
|
|
32
|
+ SECTION:=libs
|
|
33
|
+ CATEGORY:=Libraries
|
|
34
|
+ TITLE:=Gnome XML library
|
|
35
|
+ URL:=http://xmlsoft.org/
|
|
36
|
+ DEPENDS:=+libpthread +zlib
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+define Package/libxml2/description
|
|
40
|
+ A library for manipulating XML and HTML resources.
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+TARGET_CFLAGS += $(FPIC)
|
|
44
|
+
|
|
45
|
+CONFIGURE_ARGS += \
|
|
46
|
+ --enable-shared \
|
|
47
|
+ --enable-static \
|
|
48
|
+ --with-c14n \
|
|
49
|
+ --without-catalog \
|
|
50
|
+ --with-debug \
|
|
51
|
+ --without-docbook \
|
|
52
|
+ --with-html \
|
|
53
|
+ --without-ftp \
|
|
54
|
+ --without-http \
|
|
55
|
+ --without-iconv \
|
|
56
|
+ --without-iso8859x \
|
|
57
|
+ --without-legacy \
|
|
58
|
+ --with-output \
|
|
59
|
+ --without-pattern \
|
|
60
|
+ --without-push \
|
|
61
|
+ --without-python \
|
|
62
|
+ --with-reader \
|
|
63
|
+ --without-readline \
|
|
64
|
+ --without-regexps \
|
|
65
|
+ --with-sax1 \
|
|
66
|
+ --with-schemas \
|
|
67
|
+ --with-threads \
|
|
68
|
+ --with-tree \
|
|
69
|
+ --with-valid \
|
|
70
|
+ --with-writer \
|
|
71
|
+ --with-xinclude \
|
|
72
|
+ --with-xpath \
|
|
73
|
+ --with-xptr \
|
|
74
|
+ --with-zlib \
|
|
75
|
+ --without-lzma
|
|
76
|
+
|
|
77
|
+define Build/InstallDev
|
|
78
|
+ $(INSTALL_DIR) $(2)/bin
|
|
79
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(2)/bin/
|
|
80
|
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(2)/bin/xml2-config
|
|
81
|
+
|
|
82
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
83
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libxml2 $(1)/usr/include/
|
|
84
|
+
|
|
85
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
86
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.{la,a,so*} $(1)/usr/lib/
|
|
87
|
+
|
|
88
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
89
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxml-2.0.pc $(1)/usr/lib/pkgconfig/
|
|
90
|
+
|
|
91
|
+ $(INSTALL_DIR) $(2)/share/aclocal/
|
|
92
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(2)/share/aclocal
|
|
93
|
+endef
|
|
94
|
+
|
|
95
|
+define Package/libxml2/install
|
|
96
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
97
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.so* $(1)/usr/lib/
|
|
98
|
+endef
|
|
99
|
+
|
|
100
|
+$(eval $(call BuildPackage,libxml2))
|