|
@@ -0,0 +1,66 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2010-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=glpk
|
|
11
|
+PKG_VERSION:=4.55
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
|
16
|
+PKG_MD5SUM:=c632a7a631b8aed02e28eafcd99477f
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=GPL-3.0
|
|
19
|
+PKG_LICENSE_FILES:=COPYING
|
|
20
|
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
|
21
|
+
|
|
22
|
+PKG_INSTALL:=1
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+
|
|
26
|
+define Package/libglpk
|
|
27
|
+ SECTION:=libs
|
|
28
|
+ CATEGORY:=Libraries
|
|
29
|
+ TITLE:=The GNU Linear Programming Kit
|
|
30
|
+ URL:=http://www.gnu.org/software/glpk/
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/libglpk/description
|
|
34
|
+ The GLPK (GNU Linear Programming Kit) package is intended for solving
|
|
35
|
+ large-scale linear programming (LP), mixed integer programming (MIP),
|
|
36
|
+ and other related problems. It is a set of routines written in ANSI C
|
|
37
|
+ and organized in the form of a callable library.
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+define Package/glpsol
|
|
41
|
+ SECTION:=libs
|
|
42
|
+ CATEGORY:=Libraries
|
|
43
|
+ TITLE:=The GNU Linear Programming Kit (glpsol)
|
|
44
|
+ URL:=http://www.gnu.org/software/glpk/
|
|
45
|
+ DEPENDS:=libglpk
|
|
46
|
+endef
|
|
47
|
+
|
|
48
|
+define Build/InstallDev
|
|
49
|
+ $(INSTALL_DIR) $(1)/usr/include/
|
|
50
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
|
51
|
+ $(INSTALL_DIR) $(1)/usr/lib/
|
|
52
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+define Package/libglpk/install
|
|
56
|
+ $(INSTALL_DIR) $(1)/usr/lib/
|
|
57
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
|
58
|
+endef
|
|
59
|
+
|
|
60
|
+define Package/glpsol/install
|
|
61
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
62
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/glpsol $(1)/usr/bin
|
|
63
|
+endef
|
|
64
|
+
|
|
65
|
+$(eval $(call BuildPackage,libglpk))
|
|
66
|
+$(eval $(call BuildPackage,glpsol))
|