|
@@ -0,0 +1,44 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2012-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libuecc
|
|
11
|
+PKG_VERSION:=4
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_MAINTAINER:=Matthias Schiffer <mschiffer@universe-factory.net>
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
|
16
|
+PKG_SOURCE_URL:=https://projects.universe-factory.net/attachments/download/71
|
|
17
|
+PKG_MD5SUM:=7f44df5dc69cb8686947562e2a11eea9
|
|
18
|
+
|
|
19
|
+include $(INCLUDE_DIR)/package.mk
|
|
20
|
+include $(INCLUDE_DIR)/cmake.mk
|
|
21
|
+
|
|
22
|
+define Package/libuecc
|
|
23
|
+ SECTION:=libs
|
|
24
|
+ CATEGORY:=Libraries
|
|
25
|
+ TITLE:=Very small Elliptic Curve Cryptography library
|
|
26
|
+ URL:=http://git.universe-factory.net/libuecc/
|
|
27
|
+endef
|
|
28
|
+
|
|
29
|
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
|
|
30
|
+
|
|
31
|
+CMAKE_OPTIONS += \
|
|
32
|
+ -DCMAKE_BUILD_TYPE:String="MINSIZEREL"
|
|
33
|
+
|
|
34
|
+
|
|
35
|
+define Build/InstallDev
|
|
36
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
37
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libuecc-$(PKG_VERSION) $(1)/usr/include/
|
|
38
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
39
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuecc.a $(1)/usr/lib/
|
|
40
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
41
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libuecc.pc $(1)/usr/lib/pkgconfig/
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+$(eval $(call BuildPackage,libuecc))
|