Bladeren bron

announce: Announce services on the network with Zeroconf/Bonjour

probonopd 10 jaren geleden
bovenliggende
commit
eeec3dcb4b
1 gewijzigde bestanden met toevoegingen van 57 en 0 verwijderingen
  1. 57
    0
      net/announce/Makefile

+ 57
- 0
net/announce/Makefile Bestand weergeven

@@ -0,0 +1,57 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=announce
11
+PKG_VERSION:=1.0
12
+PKG_RELEASE:=1
13
+PKG_LICENSE:=BSD-3-Clause
14
+PKG_LICENSE_FILES:=src/LICENSE.txt
15
+PKG_MAINTAINER:=Simon Peter <probono@puredarwin.org>
16
+
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_URL:=https://github.com/probonopd/announce.git
19
+PKG_SOURCE_VERSION:=70d70f998686199deaa5d62b54688c869e237eef
20
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
21
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
22
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
23
+
24
+PKG_BUILD_PARALLEL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+PKG_BUILD_DEPENDS:= +libpthread
29
+
30
+define Package/announce
31
+	SECTION:=net
32
+	CATEGORY:=Network
33
+	SUBMENU:=IP Addresses and Names
34
+	TITLE:=Announce services on the network with Zeroconf/Bonjour 
35
+	URL:=https://github.com/probonopd/announce
36
+	DEPENDS:= +libpthread 
37
+endef
38
+
39
+define Package/announce/description
40
+  Announce services on the network with Zeroconf/Bonjour.
41
+  This announces services such as ssh, sftp, and http running on the local machine
42
+  to the network.
43
+endef
44
+
45
+define Build/Prepare
46
+	$(call Build/Prepare/Default)
47
+	$(CP) $(PKG_BUILD_DIR)/src/* $(PKG_BUILD_DIR)/
48
+endef
49
+
50
+define Package/announce/install
51
+	$(INSTALL_DIR) $(1)/usr/sbin
52
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/announce $(1)/usr/sbin/
53
+	$(INSTALL_DIR) $(1)/etc/init.d
54
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/announce.initscript $(1)/etc/init.d/announce
55
+endef
56
+
57
+$(eval $(call BuildPackage,announce))