Browse Source

openconnect: updated to 7.00

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 years ago
parent
commit
efcae14f20

+ 5
- 4
net/openconnect/Makefile View File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=openconnect
11
-PKG_VERSION:=6.00
12
-PKG_RELEASE:=4
11
+PKG_VERSION:=7.00
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/openconnect/
16
-PKG_MD5SUM:=7e28e23c6e281be31446e6c365f5d273
16
+PKG_MD5SUM:=208b03fb66cd8e26633a19b9e12f35af
17 17
 
18 18
 PKG_CONFIG_DEPENDS:= \
19 19
 	CONFIG_OPENCONNECT_GNUTLS \
@@ -47,7 +47,8 @@ endef
47 47
 
48 48
 CONFIGURE_ARGS += \
49 49
 	--disable-shared \
50
-	--with-vpnc-script=/lib/netifd/vpnc-script
50
+	--with-vpnc-script=/lib/netifd/vpnc-script \
51
+	--without-libpcsclite
51 52
 
52 53
 ifeq ($(CONFIG_OPENCONNECT_OPENSSL),y)
53 54
 CONFIGURE_ARGS += \

+ 0
- 30
net/openconnect/patches/001-Added-a-default-timeout-value-in-CSTP-handshake-usin.patch View File

@@ -1,31 +0,0 @@
1
-From 826ad45a86f1556910c2f00dfa6477879deb978f Mon Sep 17 00:00:00 2001
2
-From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
3
-Date: Thu, 24 Jul 2014 21:59:01 +0200
4
-Subject: [PATCH] Added a default timeout value in CSTP handshake using gnutls
5
-
6
-[dwmw2: move it to openconnect_open_https() so it's done only once]
7
-
8
-Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
9
-Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
10
----
11
- gnutls.c | 4 ++++
12
- 1 file changed, 4 insertions(+)
13
-
14
-diff --git a/gnutls.c b/gnutls.c
15
-index 3e3204a..2ef836c 100644
16
---- a/gnutls.c
17
-+++ b/gnutls.c
18
-@@ -2017,6 +2017,10 @@ int openconnect_open_https(struct openconnect_info *vpninfo)
19
- 	vpn_progress(vpninfo, PRG_INFO, _("SSL negotiation with %s\n"),
20
- 		     vpninfo->hostname);
21
- 
22
-+#ifdef GNUTLS_DEFAULT_HANDSHAKE_TIMEOUT
23
-+	gnutls_handshake_set_timeout(vpninfo->https_sess,
24
-+				     GNUTLS_DEFAULT_HANDSHAKE_TIMEOUT);
25
-+#endif
26
- 
27
- 	err = cstp_handshake(vpninfo, 1);
28
- 	if (err)
29
-2.0.0
30
-

+ 22
- 0
net/openconnect/patches/001-always-resolve-ips.patch View File

@@ -0,0 +1,22 @@
1
+diff --git a/cstp.c b/cstp.c
2
+index b1235ef..05c3444 100644
3
+--- a/cstp.c
4
++++ b/cstp.c
5
+@@ -591,6 +591,8 @@ static int cstp_reconnect(struct openconnect_info *vpninfo)
6
+ 	timeout = vpninfo->reconnect_timeout;
7
+ 	interval = vpninfo->reconnect_interval;
8
+ 
9
++	free(vpninfo->peer_addr); 
10
++	vpninfo->peer_addr = NULL;
11
+ 	while ((ret = openconnect_make_cstp_connection(vpninfo))) {
12
+ 		if (timeout <= 0)
13
+ 			return ret;
14
+@@ -611,6 +613,8 @@ static int cstp_reconnect(struct openconnect_info *vpninfo)
15
+ 		interval += vpninfo->reconnect_interval;
16
+ 		if (interval > RECONNECT_INTERVAL_MAX)
17
+ 			interval = RECONNECT_INTERVAL_MAX;
18
++		free(vpninfo->peer_addr); 
19
++		vpninfo->peer_addr = NULL;
20
+ 	}
21
+ 	script_config_tun(vpninfo, "reconnect");
22
+ 	return 0;