Browse Source

Merge pull request #762 from jow-/smartmontools-autoreconf

smartmontools: use generic autoreconf fixup
Jo-Philipp Wich 10 years ago
parent
commit
efe52d2fe5
1 changed files with 2 additions and 7 deletions
  1. 2
    7
      utils/smartmontools/Makefile

+ 2
- 7
utils/smartmontools/Makefile View File

@@ -19,6 +19,8 @@ PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
19 19
 PKG_LICENSE:=GPL-2.0+
20 20
 PKG_LICENSE_FILES:=COPYING
21 21
 
22
+PKG_FIXUP:=autoreconf
23
+
22 24
 include $(INCLUDE_DIR)/package.mk
23 25
 
24 26
 define Package/smartmontools/Default
@@ -61,13 +63,6 @@ CONFIGURE_VARS += \
61 63
 	LDFLAGS="$$$$LDFLAGS" \
62 64
 	LIBS="-nodefaultlibs -lc -luClibc++ -lm $(LIBGCC_S) -lc" \
63 65
 
64
-define Build/Configure
65
-	(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
66
-		./autogen.sh \
67
-	);
68
-	$(call Build/Configure/Default)
69
-endef
70
-
71 66
 define Build/Compile
72 67
 	$(MAKE) -C $(PKG_BUILD_DIR) \
73 68
 		BUILD_INFO='"(localbuild)"' \