|
@@ -0,0 +1,335 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2009-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=erlang
|
|
11
|
+PKG_VERSION:=17.1
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=otp_src_$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:= http://www.erlang.org/download/ \
|
|
16
|
+ http://erlang.mirror.su.se/
|
|
17
|
+PKG_MD5SUM:=9c90706ce70e01651adde34a2b79bf4c
|
|
18
|
+
|
|
19
|
+PKG_LICENSE:=ErlPL-1.1
|
|
20
|
+PKG_LICENSE_FILE:=EPLICENCE
|
|
21
|
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
|
|
22
|
+
|
|
23
|
+PKG_BUILD_DEPENDS:=erlang/host openssl
|
|
24
|
+
|
|
25
|
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/otp_src_$(PKG_VERSION)
|
|
26
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/otp_src_$(PKG_VERSION)
|
|
27
|
+
|
|
28
|
+include $(INCLUDE_DIR)/host-build.mk
|
|
29
|
+include $(INCLUDE_DIR)/package.mk
|
|
30
|
+
|
|
31
|
+define Package/erlang/Default
|
|
32
|
+ SUBMENU:=Erlang
|
|
33
|
+ SECTION:=lang
|
|
34
|
+ CATEGORY:=Languages
|
|
35
|
+ TITLE:=Erlang/OTP programming language
|
|
36
|
+ URL:=http://www.erlang.org/
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+define Package/erlang/Default/description
|
|
40
|
+ Erlang/OTP is a general-purpose programming language and runtime
|
|
41
|
+ environment. Erlang has built-in support for concurrency, distribution
|
|
42
|
+ and fault tolerance.
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+define Package/erlang
|
|
46
|
+$(call Package/erlang/Default)
|
|
47
|
+ DEPENDS+= +libncurses +librt +zlib
|
|
48
|
+ PROVIDES:= erlang-erts=6.1 erlang-kernel=3.0.1 erlang-sasl=2.4 erlang-stdlib=2.1
|
|
49
|
+endef
|
|
50
|
+
|
|
51
|
+define Package/erlang/description
|
|
52
|
+$(call Package/erlang/Default/description)
|
|
53
|
+ .
|
|
54
|
+ This package contains the runtime implementation and a minimal set of
|
|
55
|
+ modules (erts, kernel, sasl & stdlib).
|
|
56
|
+endef
|
|
57
|
+
|
|
58
|
+
|
|
59
|
+define Package/erlang-asn1
|
|
60
|
+$(call Package/erlang/Default)
|
|
61
|
+ TITLE:=Abstract Syntax Notation One (ASN.1) support
|
|
62
|
+ VERSION:=3.0.1
|
|
63
|
+ DEPENDS+= +erlang +erlang-syntax-tools
|
|
64
|
+endef
|
|
65
|
+
|
|
66
|
+define Package/erlang-asn1/description
|
|
67
|
+$(call Package/erlang/Default/description)
|
|
68
|
+ .
|
|
69
|
+ This Erlang/OTP package provides Abstract Syntax Notation One (ASN.1)
|
|
70
|
+ support.
|
|
71
|
+endef
|
|
72
|
+
|
|
73
|
+
|
|
74
|
+define Package/erlang-compiler
|
|
75
|
+$(call Package/erlang/Default)
|
|
76
|
+ TITLE:=Byte code compiler
|
|
77
|
+ VERSION:=5.0.1
|
|
78
|
+ DEPENDS+= +erlang +erlang-hipe
|
|
79
|
+endef
|
|
80
|
+
|
|
81
|
+define Package/erlang-compiler/description
|
|
82
|
+$(call Package/erlang/Default/description)
|
|
83
|
+ .
|
|
84
|
+ This Erlang/OTP package provides a byte code compiler for Erlang which
|
|
85
|
+ produces highly compact code.
|
|
86
|
+endef
|
|
87
|
+
|
|
88
|
+
|
|
89
|
+define Package/erlang-crypto
|
|
90
|
+$(call Package/erlang/Default)
|
|
91
|
+ TITLE:=Cryptography support
|
|
92
|
+ VERSION:=3.4
|
|
93
|
+ DEPENDS+= +erlang +libopenssl
|
|
94
|
+endef
|
|
95
|
+
|
|
96
|
+define Package/erlang-crypto/description
|
|
97
|
+$(call Package/erlang/Default/description)
|
|
98
|
+ .
|
|
99
|
+ This Erlang/OTP package provides functions for computation of message
|
|
100
|
+ digests, and encryption and decryption functions.
|
|
101
|
+endef
|
|
102
|
+
|
|
103
|
+
|
|
104
|
+define Package/erlang-hipe
|
|
105
|
+$(call Package/erlang/Default)
|
|
106
|
+ TITLE:=High Performance Erlang
|
|
107
|
+ VERSION:=3.11
|
|
108
|
+ DEPENDS+= +erlang
|
|
109
|
+endef
|
|
110
|
+
|
|
111
|
+define Package/erlang-hipe/description
|
|
112
|
+$(call Package/erlang/Default/description)
|
|
113
|
+ .
|
|
114
|
+ This Erlang/OTP package provides HiPE (High Performance Erlang)
|
|
115
|
+ support.
|
|
116
|
+endef
|
|
117
|
+
|
|
118
|
+
|
|
119
|
+define Package/erlang-inets
|
|
120
|
+$(call Package/erlang/Default)
|
|
121
|
+ TITLE:=Internet clients and servers
|
|
122
|
+ VERSION:=5.10.2
|
|
123
|
+ DEPENDS+= +erlang
|
|
124
|
+endef
|
|
125
|
+
|
|
126
|
+define Package/erlang-inets/description
|
|
127
|
+$(call Package/erlang/Default/description)
|
|
128
|
+ .
|
|
129
|
+ This Erlang/OTP package provides a container for Internet clients and
|
|
130
|
+ servers. Currently a FTP client, a HTTP client and server, and a tftp
|
|
131
|
+ client and server have been incorporated in Inets.
|
|
132
|
+endef
|
|
133
|
+
|
|
134
|
+
|
|
135
|
+define Package/erlang-mnesia
|
|
136
|
+$(call Package/erlang/Default)
|
|
137
|
+ TITLE:=Distributed database
|
|
138
|
+ VERSION:=4.12.1
|
|
139
|
+ DEPENDS+= +erlang
|
|
140
|
+endef
|
|
141
|
+
|
|
142
|
+define Package/erlang-mnesia/description
|
|
143
|
+$(call Package/erlang/Default/description)
|
|
144
|
+ .
|
|
145
|
+ This Erlang/OTP package provides a distributed DataBase Management
|
|
146
|
+ System (DBMS), appropriate for telecommunications applications and
|
|
147
|
+ other Erlang applications which require continuous operation and
|
|
148
|
+ exhibit soft real-time properties.
|
|
149
|
+endef
|
|
150
|
+
|
|
151
|
+
|
|
152
|
+define Package/erlang-runtime-tools
|
|
153
|
+$(call Package/erlang/Default)
|
|
154
|
+ TITLE:=Low-profile debugging/tracing tools
|
|
155
|
+ VERSION:=1.8.14
|
|
156
|
+ DEPENDS+= +erlang
|
|
157
|
+endef
|
|
158
|
+
|
|
159
|
+define Package/erlang-runtime-tools/description
|
|
160
|
+$(call Package/erlang/Default/description)
|
|
161
|
+ .
|
|
162
|
+ This Erlang/OTP package provides low footprint tracing/debugging tools
|
|
163
|
+ suitable for inclusion in a production system.
|
|
164
|
+endef
|
|
165
|
+
|
|
166
|
+
|
|
167
|
+define Package/erlang-snmp
|
|
168
|
+$(call Package/erlang/Default)
|
|
169
|
+ TITLE:=Simple Network Management Protocol (SNMP) support
|
|
170
|
+ VERSION:=4.25.1
|
|
171
|
+ DEPENDS+= +erlang +erlang-asn1
|
|
172
|
+endef
|
|
173
|
+
|
|
174
|
+define Package/erlang-snmp/description
|
|
175
|
+$(call Package/erlang/Default/description)
|
|
176
|
+ .
|
|
177
|
+ This Erlang/OTP package provides Simple Network Management Protocol
|
|
178
|
+ (SNMP) support including a MIB compiler and tools for creating SNMP
|
|
179
|
+ agents.
|
|
180
|
+endef
|
|
181
|
+
|
|
182
|
+
|
|
183
|
+define Package/erlang-ssh
|
|
184
|
+$(call Package/erlang/Default)
|
|
185
|
+ TITLE:=Secure Shell (SSH) support
|
|
186
|
+ VERSION:=3.0.3
|
|
187
|
+ DEPENDS+= +erlang +erlang-crypto
|
|
188
|
+endef
|
|
189
|
+
|
|
190
|
+define Package/erlang-ssh/description
|
|
191
|
+$(call Package/erlang/Default/description)
|
|
192
|
+ .
|
|
193
|
+ This Erlang/OTP package provides an implementation of the Secure Shell
|
|
194
|
+ protocol, with SSH & SFTP support.
|
|
195
|
+endef
|
|
196
|
+
|
|
197
|
+
|
|
198
|
+define Package/erlang-ssl
|
|
199
|
+$(call Package/erlang/Default)
|
|
200
|
+ TITLE:=Secure Sockets Layer (SSL) support
|
|
201
|
+ VERSION:=5.3.5
|
|
202
|
+ DEPENDS+= +erlang +erlang-crypto
|
|
203
|
+endef
|
|
204
|
+
|
|
205
|
+define Package/erlang-ssl/description
|
|
206
|
+$(call Package/erlang/Default/description)
|
|
207
|
+ .
|
|
208
|
+ This Erlang/OTP package provides support for secure communication over
|
|
209
|
+ sockets.
|
|
210
|
+endef
|
|
211
|
+
|
|
212
|
+
|
|
213
|
+define Package/erlang-syntax-tools
|
|
214
|
+$(call Package/erlang/Default)
|
|
215
|
+ TITLE:=Abstract Erlang syntax trees handling support
|
|
216
|
+ VERSION:=1.6.15
|
|
217
|
+ DEPENDS+= +erlang
|
|
218
|
+endef
|
|
219
|
+
|
|
220
|
+define Package/erlang-syntax-tools/description
|
|
221
|
+$(call Package/erlang/Default/description)
|
|
222
|
+ .
|
|
223
|
+ This Erlang/OTP package provides support for handling abstract Erlang
|
|
224
|
+ syntax trees.
|
|
225
|
+endef
|
|
226
|
+
|
|
227
|
+
|
|
228
|
+# Host
|
|
229
|
+
|
|
230
|
+HOST_CONFIGURE_ARGS += \
|
|
231
|
+ --disable-hipe \
|
|
232
|
+ --disable-smp-support \
|
|
233
|
+ --without-javac
|
|
234
|
+
|
|
235
|
+define Host/Compile
|
|
236
|
+ $(MAKE) -C $(HOST_BUILD_DIR) all
|
|
237
|
+endef
|
|
238
|
+
|
|
239
|
+define Host/Install
|
|
240
|
+ $(MAKE) -C $(HOST_BUILD_DIR) install
|
|
241
|
+endef
|
|
242
|
+
|
|
243
|
+
|
|
244
|
+# Target
|
|
245
|
+
|
|
246
|
+CONFIGURE_ARGS += \
|
|
247
|
+ --disable-hipe \
|
|
248
|
+ --disable-smp-support \
|
|
249
|
+ --without-javac \
|
|
250
|
+ --enable-dynamic-ssl-lib
|
|
251
|
+
|
|
252
|
+CONFIGURE_VARS += \
|
|
253
|
+ SHLIB_LD="$(TARGET_CC)" \
|
|
254
|
+ TARGET_ARCH="$(TARGET_ARCH)" \
|
|
255
|
+ ac_cv_func_mmap_fixed_mapped=yes \
|
|
256
|
+ ac_cv_path_WX_CONFIG_PATH=no \
|
|
257
|
+ erl_xcomp_getaddrinfo=no \
|
|
258
|
+ erl_xcomp_sysroot="$(STAGING_DIR)"
|
|
259
|
+
|
|
260
|
+EXTRA_LDFLAGS+=-lz
|
|
261
|
+
|
|
262
|
+define Build/Compile
|
|
263
|
+ $(MAKE) -C $(PKG_BUILD_DIR) \
|
|
264
|
+ noboot
|
|
265
|
+ $(MAKE) -C $(PKG_BUILD_DIR) \
|
|
266
|
+ INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
|
|
267
|
+ install
|
|
268
|
+endef
|
|
269
|
+
|
|
270
|
+define Package/erlang/install
|
|
271
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
272
|
+ for f in epmd erl erlc escript run_erl; do \
|
|
273
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/$$$$f $(1)/usr/bin/ ; \
|
|
274
|
+ done
|
|
275
|
+ $(INSTALL_DIR) $(1)/usr/lib/erlang/bin
|
|
276
|
+ for f in erl erlc escript run_erl start start.boot start.script start_clean.boot start_erl start_sasl.boot to_erl; do \
|
|
277
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/erlang/bin/$$$$f $(1)/usr/lib/erlang/bin/ ; \
|
|
278
|
+ done
|
|
279
|
+ $(INSTALL_DIR) $(1)/usr/lib/erlang/lib
|
|
280
|
+ for m in erts kernel sasl stdlib; do \
|
|
281
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/erlang/lib/$$$$m-* $(1)/usr/lib/erlang/lib/ ; \
|
|
282
|
+ rm -rf $(1)/usr/lib/erlang/lib/$$$$m-*/examples ; \
|
|
283
|
+ rm -rf $(1)/usr/lib/erlang/lib/$$$$m-*/src ; \
|
|
284
|
+ done
|
|
285
|
+ $(INSTALL_DIR) $(1)/usr/lib/erlang
|
|
286
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/erlang/erts-* $(1)/usr/lib/erlang/
|
|
287
|
+ rm -rf $(1)/usr/lib/erlang/erts-*/{doc,include,lib,man,src}
|
|
288
|
+ rm -rf $(1)/usr/lib/erlang/erts-*/bin/*.src
|
|
289
|
+ $(INSTALL_DIR) $(1)/usr/lib/erlang/releases
|
|
290
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/erlang/releases/* $(1)/usr/lib/erlang/releases/
|
|
291
|
+ $(SED) 's,%ERL_ROOT%,/usr/lib/erlang,g' \
|
|
292
|
+ $(1)/usr/lib/erlang/releases/RELEASES.src
|
|
293
|
+ mv -f $(1)/usr/lib/erlang/releases/RELEASES.src \
|
|
294
|
+ $(1)/usr/lib/erlang/releases/RELEASES
|
|
295
|
+ for f in bin/erl bin/start erts-*/bin/erl erts-*/bin/start; do \
|
|
296
|
+ $(SED) 's,^\(ROOTDIR\)=.*,\1=/usr/lib/erlang,g' \
|
|
297
|
+ $(1)/usr/lib/erlang/$$$$f ; \
|
|
298
|
+ done
|
|
299
|
+endef
|
|
300
|
+
|
|
301
|
+define Build/InstallDev
|
|
302
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
303
|
+ $(CP) $(PKG_BUILD_DIR)/lib/erl_interface/obj/*/*.a $(1)/usr/lib
|
|
304
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
305
|
+ $(CP) $(PKG_BUILD_DIR)/lib/erl_interface/include/*.h $(1)/usr/include
|
|
306
|
+endef
|
|
307
|
+
|
|
308
|
+define BuildModule
|
|
309
|
+
|
|
310
|
+ define Package/erlang-$(1)/install
|
|
311
|
+ $(INSTALL_DIR) $$(1)/usr/lib/erlang/lib
|
|
312
|
+ for m in $(2); do \
|
|
313
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/erlang/lib/$$$$$$$$m-* $$(1)/usr/lib/erlang/lib/ ; \
|
|
314
|
+ rm -rf $$(1)/usr/lib/erlang/lib/$$$$$$$$m-*/{examples,priv/obj,src} ; \
|
|
315
|
+ done
|
|
316
|
+ endef
|
|
317
|
+
|
|
318
|
+ $$(eval $$(call BuildPackage,erlang-$(1)))
|
|
319
|
+
|
|
320
|
+endef
|
|
321
|
+
|
|
322
|
+
|
|
323
|
+$(eval $(call HostBuild))
|
|
324
|
+$(eval $(call BuildPackage,erlang))
|
|
325
|
+$(eval $(call BuildModule,asn1,asn1))
|
|
326
|
+$(eval $(call BuildModule,compiler,compiler))
|
|
327
|
+$(eval $(call BuildModule,crypto,crypto))
|
|
328
|
+$(eval $(call BuildModule,hipe,hipe))
|
|
329
|
+$(eval $(call BuildModule,inets,inets))
|
|
330
|
+$(eval $(call BuildModule,mnesia,mnesia))
|
|
331
|
+$(eval $(call BuildModule,runtime-tools,runtime_tools))
|
|
332
|
+$(eval $(call BuildModule,snmp,snmp))
|
|
333
|
+$(eval $(call BuildModule,ssh,ssh))
|
|
334
|
+$(eval $(call BuildModule,ssl,ssl))
|
|
335
|
+$(eval $(call BuildModule,syntax-tools,syntax_tools))
|