瀏覽代碼

Merge pull request #1387 from jow-/etherwake-musl-compat

etherwake: fix musl compatibility
Jo-Philipp Wich 9 年之前
父節點
當前提交
f0cb183834
共有 2 個檔案被更改,包括 19 行新增2 行删除
  1. 2
    2
      net/etherwake/Makefile
  2. 17
    0
      net/etherwake/patches/120-musl-compat.patch

+ 2
- 2
net/etherwake/Makefile 查看文件

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2007-2011 OpenWrt.org
2
+# Copyright (C) 2007-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=etherwake
11 11
 PKG_VERSION:=1.09
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
15 15
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/etherwake

+ 17
- 0
net/etherwake/patches/120-musl-compat.patch 查看文件

@@ -0,0 +1,17 @@
1
+--- a/ether-wake.c
2
++++ b/ether-wake.c
3
+@@ -82,14 +82,8 @@ static char usage_msg[] =
4
+ #include <linux/if.h>
5
+ 
6
+ #include <features.h>
7
+-#if __GLIBC__ >= 2 && __GLIBC_MINOR >= 1
8
+ #include <netpacket/packet.h>
9
+ #include <net/ethernet.h>
10
+-#else
11
+-#include <asm/types.h>
12
+-#include <linux/if_packet.h>
13
+-#include <linux/if_ether.h>
14
+-#endif
15
+ #include <netdb.h>
16
+ #include <netinet/ether.h>
17
+